SUBSIM Radio Room Forums


SUBSIM: The Web's #1 BBS for all submarine and naval simulations since 1997

Go Back   SUBSIM Radio Room Forums > Silent Hunter 3 - 4 - 5 > Silent Hunter III
Forget password? Reset here

Reply
 
Thread Tools Display Modes
Old 03-27-2010, 04:12 AM   #1
swervn69
Bilge Rat
 
Join Date: Jan 2010
Posts: 1
Downloads: 3
Uploads: 0
Default Crashes Loading Save Games: 2 Solutions

Using Silent Hunter 3, I have experienced two types of game crashes while loading save games that I have found solutions for. I see where others are experiencing similar crashes, so maybe my two solutions can point some in the right direction.

Problem # 1 (less common, but more universal - occurs in SH3 and SH4 for all installation types and mods):

I am a "save-aholic" and save the game all the time, especially during a heated battle in a large convoy. I hit Esc, click the "Save" option, input a new save game name in the box, then click the "Save" button, and the game immediately crashes to the desktop. I launch SH3 again, click "Career", Accept my profile name, then I click "Saved Career", and the game immediately crashes to the desktop again, before the Save Game List is displayed.

Solution # 1:
I have overflowed the save game directory with too many save games. I must now delete several of them to resume my career again.

a) Using Windows Explorer, open the
...\My Documents\SH3\data\cfg\Careers\<profile name>\<mission number> folder. I was on my Career Mission#33, so I opened the "32" folder
b) switch Windows Explorer to "Detail View" - click View/Details on the top menu bar
c) sort all the save games by their timestamp - click the "Date" or "Date Modified" column heading, until all the files are sorted in date order
d) scroll thru the list and pick out "non-essential" save games while avoiding the latest and most important ones - highlight blocks of save game files that all have the same name and timestamp - SH3 saves them in groups of 10 files (this folder had 1080 files in it, so I had 108 save games! Too many!)
e) delete these blocks of 10 files, until the folder is back down to a safe level - 500 or less
f) launch SH3 again, Career and latest Save Game loaded successfully! (...and next time, I was more conservative and saved over old save game names more often!) Once that Mission was over, I started a new Mission with a fresh set of save games again.


Problem # 2 (more common, but more Mod-specific; I never had this problem for 3 years on the stock SH3 install, but it happened frequently after installing GWX3 Gold and the associated Mods on the download mirror):

I attempt to load a Save Game, where I am in a heated battle in the middle of a large convoy. The Load Game progress bar loads up to 100%, then the screen goes black and displays the "Not So Long Ago..." message. Next, the Command Room starts to display for a split-second, then the game immediately drops out and crashes to the desktop.

I tried for three weeks to resolve this problem, using as many tips and tricks as I could find with google, ubi and subsim forums - no luck.

I refused to accept various explanations, like "you saved underwater", or "you saved within a gazillion kilometers of other ships, land, etc." Why? Because I have one Save Game that loads just fine, just off the coast of Hartlepool, where my XXI is underwater, in the middle of a huge convoy, sitting at the bottom, right next to a C2 that I just sunk, with a Flower Corvette bearing down on me from above. However, all subsequent Save Games fail to load with this CTD problem. If that one can load, then why can't the rest??

I did three things tonight, and my problem is solved! All my subsequent save games in the middle of this battle are now working again.

Solution # 2 (which one of these things fixed this problem?):

a) In Windows Explorer, I opened the C:\GAMES folder
b) I right-clicked on the SH3 game folder and selected "Properties"
c) On the General tab, in the Attributes section, I unchecked the "Read-only" box
d) I clicked on the Advanced button, and I unchecked the Archiving option, and I unchecked the "Index this folder" option
e) I clicked OK / Apply and selected "Apply changes to this folder, subfolders and files"
f) I opened the "My Documents" folder and right-clicked/Properties on the SH3 folder there and repeated Steps c, d, and e again
g) I launched JSGME (v2.2.0.120) and I removed the following Mods: "LifeBoats&Debris_v4", "Torpedo damage Final", and "GWX - Enhanced Damage Effects"
h) I launched SH3 again, and my "bad" Save Games loaded successfully!
i) I ran JSGME again and added those Mods back again
j) My "bad" SH3 Save Games still loaded successfully
k) I saved and loaded new Save Games, underwater, in the middle of that heated battle successfully!

What gives??
Did one of these specific Mods cause the crashes?
Is there a conflict between Mods causing these Save Game CTDs??
Do the Mods mark certain critical files "Read-only", causing Save Games to crash in the future??
Do the "Enhanced Damage" Mods cause loud explosions when the Save Games load, which cause them to CTD??

Can we pinpoint the exact solution??
swervn69 is offline   Reply With Quote
Old 03-27-2010, 05:26 AM   #2
KL-alfman
Grey Wolf
 
Join Date: Nov 2009
Location: Weimar
Posts: 924
Downloads: 84
Uploads: 0
Default

that's very valuable information!
thx for sharing your work.
__________________
Life, Liberty and Property!
KL-alfman is offline   Reply With Quote
Old 03-27-2010, 07:19 AM   #3
Rconch
Captain
 
Rconch's Avatar
 
Join Date: Jul 2002
Location: No. Virginia
Posts: 577
Downloads: 350
Uploads: 0
Default

Can we pinpoint the exact solution??

We can perhaps minimize them, but do away with all CTDs, I doubt it.
We all have different computers and mods installed.
Conflicts occur, I make sure to read the "readmes" whenever installing a mod, if uncomfortable with what I read, no go.
I take a very minimal approach on mods, running on 90% realism, I don't use any of the eye candy which seems to have bothered my computer at times in the past.
Basic GWX with 16K and a few sound mods keeps me going.
__________________
"Noch und Noch"
Prowling the Nord Atlantik with GWX 3.0.
Rconch is offline   Reply With Quote
Old 03-27-2010, 07:35 AM   #4
Jimbuna
Chief of the Boat
 
Jimbuna's Avatar
 
Join Date: Feb 2006
Location: 250 metres below the surface
Posts: 136,092
Downloads: 49
Uploads: 11


Default

Welcome to SS

Quote:
Originally Posted by swervn69 View Post

Can we pinpoint the exact solution??
I would like to think so because the saved game phenomena you describe has been an issue since the games release.

I am impressed with the efort you have put into resolving the issue and would encourage you to continue in your endevours.

Sadly, and I am trying desperately not to sound too negative, but what you have tried has already been attempted by quite a few before you.

The overriding problem is the simple fact that this is an intermittent problem which cannot be pinned down under any definitive set of circumstances.....given a prescribed set of parameters, it works on ocassion and then doesn't on others.

Keep up your work/trials and should you be successful you'll be able to count on the undying gratitude of a great many in this community.

SINK EM ALL!!
__________________
Wise men speak because they have something to say; Fools because they have to say something.
Oh my God, not again!!


GWX3.0 Download Page - Donation/instant access to GWX (Help SubSim)
Jimbuna is online   Reply With Quote
Old 03-27-2010, 09:39 AM   #5
Apache312
A-ganger
 
Join Date: Feb 2010
Location: Florida
Posts: 78
Downloads: 3
Uploads: 0
Default

With this post, it reminds me to extend thanks to all of you who make this a community. I first came to this board because of crashing issues with savegames. Since given great advice to not save near other ships, I have had zero issues with savegames, although I get the occasional crash of game when I approach a REALLY BIG convoy. At this point, whenever im not in battle, im saving, so not much is lost.

A heart felt thanks to all who help this board...

/S

Apache312
Apache312 is offline   Reply With Quote
Old 03-27-2010, 02:06 PM   #6
Vipper
Machinist's Mate
 
Join Date: Sep 2007
Posts: 121
Downloads: 8
Uploads: 0
Default

Thank you so much!!! That is what i did want to know so much, im saveaholic too
Vipper is offline   Reply With Quote
Old 05-12-2010, 01:22 AM   #7
ryanwigginton
Weps
 
Join Date: Apr 2007
Location: Nottinghamshire
Posts: 372
Downloads: 68
Uploads: 0
Default

This bug is annoying the hell out of me. Is there still no sure fire way to avoid this completely.

@jimbuna, you say this has been happening since the games release. So even forfeiting all the mods won't fix it either?
__________________
Windows 8 Pro 64-bit, Intel Core i7-2760QM @ 2.40GHz, 8GB RAM, AMD Radeon HD 6990M
ryanwigginton is offline   Reply With Quote
Old 05-12-2010, 07:37 AM   #8
Jimbuna
Chief of the Boat
 
Jimbuna's Avatar
 
Join Date: Feb 2006
Location: 250 metres below the surface
Posts: 136,092
Downloads: 49
Uploads: 11


Default

Quote:
Originally Posted by ryanwigginton View Post
This bug is annoying the hell out of me. Is there still no sure fire way to avoid this completely.

@jimbuna, you say this has been happening since the games release. So even forfeiting all the mods won't fix it either?
The same problems exist even in stock/vanilla install unfortunately.
__________________
Wise men speak because they have something to say; Fools because they have to say something.
Oh my God, not again!!


GWX3.0 Download Page - Donation/instant access to GWX (Help SubSim)
Jimbuna is online   Reply With Quote
Old 05-17-2010, 08:52 AM   #9
JohnWoo
Watch
 
Join Date: Apr 2010
Location: Belgium
Posts: 21
Downloads: 4
Uploads: 0
Default

I owe you one swervn69! You saved my 100k save
__________________
"If it's me, it would be a waste not to dance no matter what."
"Waiting and having faith is also a captain's duty."
JohnWoo is offline   Reply With Quote
Old 05-09-2012, 11:44 PM   #10
goldensleeve
Swabbie
 
Join Date: May 2012
Posts: 6
Downloads: 2
Uploads: 0
Default

Swervn, thanks a bunch bro. I followed everything you said and my save works, big time. I dont know what element it was. Havent re added gwx damage mod yet but will try later. Thansk a bunch for taking the time, bro. I really didnt wanna lose progress to that point.
goldensleeve is offline   Reply With Quote
Old 05-10-2012, 08:05 AM   #11
Osmium Steele
Ace of the Deep
 
Join Date: Apr 2011
Location: Upper midwest USA
Posts: 1,107
Downloads: 21
Uploads: 0


Default

I've been singing the praises of the "Read-only" trick for a year now.

Glad to hear of another believer!
__________________
In the month of July of the year 1348, between the feasts of St. Benedict and of St. Swithin,
a strange thing came upon England...


My U297 build thread
Osmium Steele is offline   Reply With Quote
Old 05-10-2012, 08:47 AM   #12
Sailor Steve
Really feelin' it.
 
Sailor Steve's Avatar
 
Join Date: Nov 2002
Location: High in the mountains of Utah
Posts: 51,309
Downloads: 630
Uploads: 250


Default

Quote:
Originally Posted by goldensleeve View Post
Swervn, thanks a bunch bro. I followed everything you said and my save works, big time. I dont know what element it was. Havent re added gwx damage mod yet but will try later. Thansk a bunch for taking the time, bro. I really didnt wanna lose progress to that point.
I'm sure he would appreciate your thanks if that post two years ago wasn't the first, last and only time he ever looked at these forums.
__________________
"An imbalance between rich and poor is the oldest and most fatal ailment of all republics."
—Plato



Sailor Steve is offline   Reply With Quote
Old 10-07-2012, 02:52 AM   #13
Nobon
Ob. z. s.
 
Nobon's Avatar
 
Join Date: Sep 2012
Location: 1939-09-13. U-50 ran into a 10+ ship british convoy- I'm planning the approach
Posts: 103
Downloads: 73
Uploads: 2
SHO

Greetings.


Well, I didnt know about the "read only" steps, maybe they resolved alot of guys problems, doesnt worked for me.

But removing those two mods, then loading:

Worked fine.

The game paused after the "Not so long ago...", in a way it -never- did, (only CTD, or the room flinges fluently after the text) so I presumed its another CTD, but then suddenly went on, and everything is fine.

Made a new savegame, and reenabled those mods.



By the way:


Until know, most of my CTD's (experimented with alot of mods, in not very lucky combinations) are solved by deinstallign all mods in jsgme, then load the game, (usually ctd's while loading) then reinstall in some different order, and voila, it works.

But in this particular case, your suggestion about those two mods worked just fine.

I have an idea why... Lying down the technological blabbing in a hour or two, but I have to go now.

Edit:

Well, both mods (especially the GWX, as the other is just 2 tga. My very favourite mod thou' ) enhance the damage of the environment. Therefore uses ram, or virtual ram.
I mean, If there was a large battle, (or an enormous monstrocity burn in 25 places, as the channel too shallow and he cant sink... Hehe, damn Revenge class in my last battle XD) suddenly there are a lots of effects to control. Maybe thats sometimes too mutch even for a better computer, to load it back in one piece.

Not to mention if theres some overlapping in coordinates, etc., which maybe isnt a problem, when slowly generates, step by step, and overwrite eachother, via the battle, but if you want to load it back, its too mutch. (and maybe something also conflicts- as far as I know Sh3 arent simply mirrores the piece of information from ram to savegame, as a database, nor it writes variables in a similar manner in one array, but uses a rather complicated mechanism. You can guess it by the way those weird things happen even in stock Sh3, when after a load everything shakes, old damages, and radio messages sound up, etc.
Seems like it loads "happened" things in a chronological order, step-by-step, as "events". Not in one piece. Many chance to a bug, especially with tons of sometimes conflicting mod. The way that it produces tons of files for one simple savegame, also reveals this questionable method.

Thats why it Usually helps for me, to disable large mods, load without ctd, save, and enable all again.
Or, If ctd still occurs, then unloading all mod, and trying to install in slightly different order- used to help.

Imagine, SH3's 7 years old VERY unoptimal (in data processing at least. as a mathematic-geometric-physics-calculation production, its remarkable) engine arent designed to load THAT mutch of beautidul 3d, effects, and scripts, which produced in a GWXv3 battle, with some graphical enhancement also.

Eeee... So I figured this out after tons of CTD's, and via digging up the career files.
__________________
Oberleutnant z. s. Daniel Wolf

87% realism (100%-Cams to watch burning targets, and torpedoes run for fun..)
SH5 The Wolves of Steel Megamod- Realnav+Full manual targeting. -no contact updates, no map help.
U-50 forever - still a Smiling bastard

Last edited by Nobon; 10-07-2012 at 05:39 AM.
Nobon is offline   Reply With Quote
Old 09-07-2014, 11:56 PM   #14
Catalysis
Swabbie
 
Join Date: Nov 2011
Posts: 13
Downloads: 118
Uploads: 0
Default

Huge thanks here too. Was driving me insane trying to solve this. Works for me 100% thus far. Much appreciated.
Catalysis is offline   Reply With Quote
Old 09-10-2014, 03:17 AM   #15
Alfred Keitzer
Kapitän zur See
 
Alfred Keitzer's Avatar
 
Join Date: Jun 2007
Location: San Diego, CA
Posts: 237
Downloads: 231
Uploads: 0
Default

One of my golden rules is never implement MODs while at sea. There are linkages between save files and your game setup (as established by the game files and your implemented MODs), and changing MODs while on patrol can break these linkages in the save files. That said, I am very surprised you were able to remove MODs and get your save to work unless you added those particular MODs after the save in question. I have had maybe two or three save files go bad on me over several years of play and many MOD changes (but only made while in port). I only save when I am on the bridge (surfaced) or in the control room (submerged) at 1x TC. and I will often play just a few minutes longer (without saving again) just to make sure things look okay. Saving submerged or near convoys has never been a problem for me using this method. This is NYGM and GWX.

As for the 3 particular MODs you mention "LifeBoats&Debris_v4", "Torpedo damage Final", and "GWX - Enhanced Damage Effects", the latter two have never given me a problem.

As I remember, I did have problems with "LifeBoats&Debris_v4" and switched back to ""LifeBoats&Debris_v3B", which has given me NO problems.
Alfred Keitzer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:31 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 1995- 2019 Subsim