SUBSIM Radio Room Forums


SUBSIM: The Web's #1 BBS for all submarine and naval simulations since 1997

Go Back   SUBSIM Radio Room Forums > Subsims & Naval Games > Classic Subsims
Forget password? Reset here

Reply
 
Thread Tools Display Modes
Old 02-19-2016, 01:00 AM   #61
NefariousKoel
Ace of the Deep
 
Join Date: Nov 2002
Location: No-good Missouri scum
Posts: 1,222
Downloads: 41
Uploads: 0
Default

Quote:
Originally Posted by Julian View Post
I downloaded the V1.3 patch for my SH1 V1.00.
I unzipped it.
Went to install it and guess what came up???
That damn Window 7 compatibility 64-bit/32-bit crap again.


It just won't let me get in to install.
Wish there was some way of disabling this Windows 7 compatibility pop up box....so I could just install straight and forward without interference.

Then there is the sound issue.
I'm looking at the instruction sheet and files, I really don't know how to setup the default settings to get sound in the game.
My old Windows XP has a Sound Blaster card in it and was much easier to setup.
But this Realtek HD Audio card, I don't know. There isn't much information as to what setup it requires.

For now I am totally frustrated in trying. I know it's only a minor problem that could be solved at the click of a button, but when a Windows program is telling you what programs you can install or not, then there is a limit to it.
I would like to go back to my old WINDOWS XP...it was USER FRIENDLY.

I had the exact same issues as you. No sound other than the intro screens. My copy of Silent Hunter is from a CD-ROM with a Win95 installer for v1.00 of Silent Hunter.



Here's what I did to get it working:

The Win installer actually works in Windows7-64. So I installed it to C:\Games\Silent. Copied over the BUD files and made the previously mentioned change to SHpath.ini BUD =BUD\ At this point the game ran but I never had in-sim sounds.

The way to fix that was to install the v1.3 and v1.31 patches, kindly hosted here in Subsim's SH1 download section. Those updates are old 16-bit installers/extractors, so those EXEs will not run in a modern Windows OSes.

After unzipping the downloaded patch zips in Windows, you will need to copy & paste those files in your Silent Hunter installation folder (C:\Games\Silent for example).

From within the game's install location, drag & drop the SHV13 patch application onto your DOSbox shortcut on your desktop (I use this method to quickly start DOS programs in DOSbox). It will unpack. Then, you will have to run the PATCH.bat file and let it run for a bit to perform the update. Once the PATCH.bat file is finished, you'll be back at the C:> prompt in DOSbox so you can just enter the EXIT command to close it because it is done.

Now you'll unzip the v1.31 patch, copy the SH131 app file over to your silent hunter install folder, then drag and drop that one onto DOSbox shortcut too. It should prompt you for a Y/N permission to overwrite your SH.EXE file. Y and enter to accept. Once it's back to the C prompt, all the installation & updating is done.

Now drag and drop the SETSOUND exe onto your DOSbox shortcut to run the sound setup. For me, the Soundblaster 16 was already selected. It will be that same for you so choose that and then select the next default option that pops up too (Automatic setup iirc) and then it should say it's finished. Highlight "Done" and hit enter to finish.

Now type in SH.EXE at the C prompt to run the game. Or exit the DOSbox prompt and drag & drop the SH app file onto the DOSbox icon again if you don't feel like typing.

Should be good to go with the new updates in there!

.......

PS: My in-game sound absolutely refused to work using SH v1.00, no matter what my Sound settings. The manual values for the SB16 certainly didn't, same as yours. After patching, I didn't even have to enter the values - the game's Setsound program did it just fine.

Note: Since DOSbox is emulating older hardware & software, your actual sound card doesn't make much of a difference in this case (unless it has an issue with DOSbox itself). DOSbox is set, by default, to emulate a Soundblaster16 in it's Settings file.
__________________
"When Gary told me he had found Jesus, I thought, Yahoo! We're rich! But it turned out to be something different." - Jack Handey
NefariousKoel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:25 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 1995- 2019 Subsim