SUBSIM Radio Room Forums


SUBSIM: The Web's #1 BBS for all submarine and naval simulations since 1997

Go Back   SUBSIM Radio Room Forums > Silent Hunter 3 - 4 - 5 > Silent Hunter 5
Forget password? Reset here

Reply
 
Thread Tools Display Modes
Old 07-23-2019, 11:34 AM   #1
karl44
Nub
 
Join Date: May 2018
Location: Germany
Posts: 3
Downloads: 9
Uploads: 0
Default Terrible FPS and Lags

Hello sailors,
first I have to apologize my bad English but I am from Germany. I have recently installed Silent Hunter 5 on my laptop and wondered why the detection tool displayed a wrong graphics driver version (way too low). After that I noticed that I have very low FPS and permanent lags despite low graphics settings (no shadows, no 3D Clouds, etc.). Maybe someone had the same problem or can help me how to get it back to work? I have a NVIDIA Gtx 960m (with newest driver), Windows 10, Intel i7-6700HQ CPU 2.60GHz, 64bit and 16GB RAM.
Greetings Karl
karl44 is offline   Reply With Quote
Old 07-23-2019, 12:29 PM   #2
Aktungbby
Gefallen Engel U-666
 
Aktungbby's Avatar
 
Join Date: Jul 2013
Location: where I'm at presently
Posts: 15,264
Downloads: 18
Uploads: 0


Default Welcome aboard!

karl44,
__________________
"Only two things are infinite: The Universe and human stupidity; And I'm not too sure about the Universe..." Philip K. Dick
Aktungbby is online   Reply With Quote
Old 07-23-2019, 12:46 PM   #3
XenonSurf
The Old Man
 
Join Date: Apr 2008
Location: Germany, Italy
Posts: 1,367
Downloads: 65
Uploads: 1
Default

With some laptops there is the problem that a program cannot always recognize the main dedicated GPU, and it will go with the low performance Intel Grafics instead.


In Windows 10 you can right-click on the app (sh5.exe) to make it start with your main GPU, on older Windows versions this is far more complicated, I have no idea how to do it, but you must make sure SH5 starts with your main GPU.


Cheers and welcome to Subsim,
XS
XenonSurf is offline   Reply With Quote
Old 07-24-2019, 01:41 AM   #4
karl44
Nub
 
Join Date: May 2018
Location: Germany
Posts: 3
Downloads: 9
Uploads: 0
Default

Thank you very much for your hint!
i have tried it and now it runs a bit smoother, but still not completely. Maybe i can also change something in the NVIDIA System control or there is something else.
karl44 is offline   Reply With Quote
Old 07-24-2019, 05:50 AM   #5
XenonSurf
The Old Man
 
Join Date: Apr 2008
Location: Germany, Italy
Posts: 1,367
Downloads: 65
Uploads: 1
Default

Quote:
Originally Posted by karl44 View Post
Thank you very much for your hint!
i have tried it and now it runs a bit smoother, but still not completely. Maybe i can also change something in the NVIDIA System control or there is something else.

With your card (GTX 960M) you should run SH5 without problems if your card has 2GB VRAM or more. It's important that you close programs running in the background, or activated services that take away system RAM and processor load. Also for laptops: chose Energieoptionen > Höchstleistung in Windows.


As for NVidia settings, I have left everything default on my system (GTX 960 4GB VRAM) and also default in-game, but you can try to set the scaling options to "Fullscreen" and "Scale with GPU". Because Nvidia cards work well with cache technology this could improve your performance. Revert if it takes away too much FPS. If still you have performance problems, then instead of changing NVidia settings, reduce the grafic options in-game in the game options.

Last edited by XenonSurf; 07-24-2019 at 06:00 AM.
XenonSurf is offline   Reply With Quote
Old 07-25-2019, 10:03 AM   #6
karl44
Nub
 
Join Date: May 2018
Location: Germany
Posts: 3
Downloads: 9
Uploads: 0
Default

Thanks mate, I have tried a bit in my options and now it runs mostly fine and fluently.
karl44 is offline   Reply With Quote
Old 07-28-2019, 07:50 PM   #7
AP514
A-ganger
 
Join Date: Feb 2019
Posts: 70
Downloads: 1
Uploads: 0
Default

GTX 960M..you must have a LENOVO Y700 ?
AP514 is offline   Reply With Quote
Reply

Tags
gtx 960m , low fps , nvidia

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:34 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 1995- 2019 Subsim