SUBSIM Radio Room Forums


SUBSIM: The Web's #1 BBS for all submarine and naval simulations since 1997

Go Back   SUBSIM Radio Room Forums > Silent Hunter 3 - 4 - 5 > Silent Hunter 4: Wolves of the Pacific
Forget password? Reset here

Reply
 
Thread Tools Display Modes
Old 12-08-2018, 02:49 PM   #1
Greystone
Helmsman
 
Join Date: Apr 2007
Location: San Francisco area
Posts: 105
Downloads: 110
Uploads: 0
Default Accidental torpedo loss

Every now and then I'll lose a torpedo by accidentally hitting the Enter key.
How do I change the default "Fire" key from Enter to Ctrl + Enter?
Thanks..

Last edited by Greystone; 12-09-2018 at 12:34 PM.
Greystone is offline   Reply With Quote
Old 12-08-2018, 07:30 PM   #2
Greystone
Helmsman
 
Join Date: Apr 2007
Location: San Francisco area
Posts: 105
Downloads: 110
Uploads: 0
Default

I ran across info I saved from my SH3 install that changed the input for the Fire Torpedo command from Enter to Ctrl+Enter, and implemented the change I made in SH3 over to SH4 and it accomplished what I was looking for. I can now fire a torpedo using Ctrl + Enter, and when I hit Enter alone nothing happens.



For SH4, go into the Data\Cfg folder and locate the commands.cfg file.
Open it and Scroll down to the [Cmd313] section.


This is how it will look:
[Cmd313]
Name=Fire_torpedo
Ctxt=1
Key0=0x0D,,"Enter"


Change it to this:
[Cmd313]
Name=Fire_torpedo
Ctxt=1
Key0=0x0D,c,"Ctl+Enter"


(You only have to alter the last line)

Last edited by Greystone; 12-09-2018 at 08:35 PM.
Greystone is offline   Reply With Quote
Old 12-08-2018, 08:28 PM   #3
mark bonamer
Sonar Guy
 
mark bonamer's Avatar
 
Join Date: Sep 2007
Location: Chicagoarea
Posts: 398
Downloads: 249
Uploads: 2
Default

Quote:
Originally Posted by Greystone View Post
I ran across info I saved from my SH3 install that changed the input for the Fire Torpedo command from Enter to Ctrl+Enter, and implemented the change I made in SH3 over to SH4 and it accomplished what I was looking for. I can now fire a torpedo using Ctrl + Enter, and when I hit Enter alone nothing happens.



For SH4, go into the Data\Cfg folder and locate the commands.cfg file.
Scroll down to [Cmd313].


This is how it will look:
[Cmd313]
Name=Fire_torpedo
Ctxt=1
Key0=0x0D,,"Enter"


Change it to this:
[Cmd313]
Name=Fire_torpedo
Ctxt=1
Key0=0x0D,c,"Ctl+Enter"


(I only had to alter the last line)

yep....do just as Greystone describes.
there is jimimadrid's Keyboard utility in the downloads section. even if you want to use Notepad to edit the file it helps to find the functions of every key. very handy.
__________________
there are only two things in the world: submarines and targets.


-------------------------------------------------------------
Silent Hunter 4 1.5 Gold Edition on CDROM
LAA enabled
Dell XPS with 8 GB Ram running Win7
mark bonamer is offline   Reply With Quote
Old 12-09-2018, 01:09 PM   #4
jimmbbo
Seaman
 
Join Date: Jun 2016
Posts: 41
Downloads: 10
Uploads: 0
Default Editing .cfg in NotePad

Was glad to find this fix for inadvertently firing torpedoes while accelerating game time.

I copied the Commands.cfg file to Commands ORIG.cfg, opened the Commands.cfg file with Notepad, and made the changes.

Saved the file and noticed the file name was ".cfg" but its type was now "text document" instead of "CFG file". SH4 would open but went to a black screen with SH4 mouse cursor when trying to load a game...

How can I to save the file as a .cfg file instead of .txt?
TIA!
jimmbbo is online   Reply With Quote
Old 12-09-2018, 06:12 PM   #5
Greystone
Helmsman
 
Join Date: Apr 2007
Location: San Francisco area
Posts: 105
Downloads: 110
Uploads: 0
Default

jimmbbo; If it's not one thing, it's another, huh? Not clear on how things turned out the way they did for you, but I can go through the steps I took.


I located the Commands.cfg file within the Data\Cfg folder and double-clicked on it.


This resulted in a new window opening up called Commands.cfg - Notepad ( the name's at the upper left of the window).


I scrolled down that window until I located the [313] section, where I changed the last line in that section from Key0=0x0D,,"Enter" to Key0=0x0D,c,"Ctl+Enter".

I then closed the window (clicked on the red X at the upper right of the window) and acknowledged that I wanted to save the changes in the resulting dialog box.


That's it good luck...
Greystone is offline   Reply With Quote
Old 12-09-2018, 11:13 PM   #6
jimmbbo
Seaman
 
Join Date: Jun 2016
Posts: 41
Downloads: 10
Uploads: 0
Default

Thanks, Greystone...
Unsure which move fixed the problem, but I selected NotePad to be RUN AS ADMINISTRATOR, then located the CFG folder and removed its "READ ONLY" feature by right clicking it, selecting PROPERTIES and unchecking that box... Worked a treat! No more firing torpedoes due to dumb thumbing the ENTER key!
jimmbbo is online   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:32 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 1995- 2019 Subsim