SUBSIM Radio Room Forums
Glue, paint, razors...what could go wrong?


SUBSIM: The Web's #1 resource for all submarine & naval simulations since 1997

Go Back   SUBSIM Radio Room Forums > Silent Hunter 3 - 4 - 5 > Silent Hunter III
Forget password? Reset here

Reply
 
Thread Tools Display Modes
Old 03-16-2021, 03:01 PM   #1
LuteFlute
Watch
 
Join Date: Mar 2021
Location: Philippines
Posts: 17
Downloads: 43
Uploads: 0
Icon9 Base GWX3.0 crashing

Hey everyone, I'm new around here, and just discovered the joy of SH3, coming from U-BOAT, the gameplay and features in SH3 are awesome (thanks to the mods)

Anyways, I've been playing SH3 (steam version) for the past 3 days with this mod setup, and have never got it to work flawlessly
It would crash towards the end of loading the menu or a mission (from the port or save). The thing is, sometimes I am able to load fine and pray to god it works from thereon. It also turns out that in-game it does crash sometimes, (noticed this occurs usually around the bay of northern France, Belgium, and the Netherlands, could be just a coincidence) which finally broke me, as I just couldn't progress anymore.

As such, I tried to do a fresh installation (deleted everything SH3 related) to try and test each mod one by one (should have done this before I know...). I tried out SH3 with just GWX 3.0 and yup, still crashes. I'm lost, if anyone, got any other ideas, I'll gladly listen. Anyways, I'm gonna go to bed as it's late, and trying to fix this has been driving me crazy. Sidenote: crashes could be from my RAM sticks, as they are iffy for some games, so I'll test this out and update this thread with the results after I wake up.

Thanks!

EDIT: Unfortunately (or fortunately for the sticks themselves) the tested RAM sticks also crash.
Attached Images
File Type: jpg Modlist in case it doesnt laod in the post.jpg (19.8 KB, 9 views)

Last edited by LuteFlute; 03-16-2021 at 06:10 PM. Reason: Issue Update
LuteFlute is offline   Reply With Quote
Old 03-16-2021, 04:15 PM   #2
John Pancoast
Ocean Warrior
 
Join Date: Apr 2002
Location: Minnysoda
Posts: 3,052
Downloads: 476
Uploads: 4


Default

Quote:
Originally Posted by LuteFlute View Post
Hey everyone, I'm new around here, and just discovered the joy of SH3, coming from U-BOAT, the gameplay and features in SH3 are awesome (thanks to the mods)

Anyways, I've been playing SH3 (steam version) for the past 3 days with this mod setup, and have never got it to work flawlessly
It would crash towards the end of loading the menu or a mission (from the port or save). The thing is, sometimes I am able to load fine and pray to god it works from thereon. It also turns out that in-game it does crash sometimes, (noticed this occurs usually around the bay of northern France, Belgium, and the Netherlands, could be just a coincidence) which finally broke me, as I just couldn't progress anymore.

As such, I tried to do a fresh installation (deleted everything SH3 related) to try and test each mod one by one (should have done this before I know...). I tried out SH3 with just GWX 3.0 and yup, still crashes. I'm lost, if anyone, got any other ideas, I'll gladly listen. Anyways, I'm gonna go to bed as it's late, and trying to fix this has been driving me crazy. Sidenote: crashes could be from my RAM sticks, as they are iffy for some games, so I'll test this out and update this thread with the results after I wake up.

Thanks!
In terms of your mod list, the TKSS u-boats and the ARB gui eat up memory.
In terms of saves some general SH3 rules to prevent corrupt saves/ctds.
- only save on the surface.
- only save when 50km or more from land and/or other ships.
- I've had the best luck saving from the navigation map screen.
If any of your saves have "broke" these guidelines, your save may be corrupted causing even base GWX to ctd in which case a re-install is advised.
__________________
"Realistic" is not always GAME-GOOD." - Wave Skipper
John Pancoast is offline   Reply With Quote
Old 03-16-2021, 04:55 PM   #3
Aktungbby
Gefallen Engel U-666
 
Aktungbby's Avatar
 
Join Date: Jul 2013
Location: where I'm at presently
Posts: 23,964
Downloads: 21
Uploads: 0


Default welcome aboard!

LuteFlute!
__________________
"Only two things are infinite; The Universe and human stupidity; And I'm not too sure about the Universe"
Aktungbby is online   Reply With Quote
Old 03-16-2021, 06:08 PM   #4
LuteFlute
Watch
 
Join Date: Mar 2021
Location: Philippines
Posts: 17
Downloads: 43
Uploads: 0
Default

Quote:
Originally Posted by John Pancoast View Post
In terms of your mod list, the TKSS u-boats and the ARB gui eat up memory.
In terms of saves some general SH3 rules to prevent corrupt saves/ctds.
- only save on the surface.
- only save when 50km or more from land and/or other ships.
- I've had the best luck saving from the navigation map screen.
If any of your saves have "broke" these guidelines, your save may be corrupted causing even base GWX to ctd in which case a re-install is advised.
All right, thanks for the general info on how to use SH3, especially with the saves. I think I should have enough memory, 16gb. Also, I have reinstalled GWX as a base to no avail, which is the reason why I am confused.
LuteFlute is offline   Reply With Quote
Old 03-16-2021, 06:19 PM   #5
John Pancoast
Ocean Warrior
 
Join Date: Apr 2002
Location: Minnysoda
Posts: 3,052
Downloads: 476
Uploads: 4


Default

Quote:
Originally Posted by LuteFlute View Post
All right, thanks for the general info on how to use SH3, especially with the saves. I think I should have enough memory, 16gb. Also, I have reinstalled GWX as a base to no avail, which is the reason why I am confused.
The saves are kept separate from the game in path "drive\my documents\gwx" or whatever is similar for your OS. That (entire folder) needs to be deleted too before a re-install.
That may be causing the current problems.
__________________
"Realistic" is not always GAME-GOOD." - Wave Skipper
John Pancoast is offline   Reply With Quote
Old 03-16-2021, 06:26 PM   #6
Jeff-Groves
Village Idiot
 
Jeff-Groves's Avatar
 
Join Date: Sep 2014
Location: Nevada, Ohio
Posts: 4,496
Downloads: 104
Uploads: 0


Default

I'd suggest patching the SH3.exe to use more RAM.
Then make sure you set compatibility mode.

Also. I'd copy a clean install from Steam to a different folder outside of the Program files areas then add GWX and the 4 GIG patch.
__________________
Professional Cunning Linguist
Don't MAKE ME get my Crayons out to draw you a picture!
Jeff-Groves is offline   Reply With Quote
Old 03-16-2021, 06:29 PM   #7
LuteFlute
Watch
 
Join Date: Mar 2021
Location: Philippines
Posts: 17
Downloads: 43
Uploads: 0
Default

Quote:
Originally Posted by John Pancoast View Post
The saves are kept separate from the game in path "drive\my documents\gwx" or whatever is similar for your OS. That (entire folder) needs to be deleted too before a re-install.
That may be causing the current problems.
Odd, I don't see any file "gwx" file, anywhere. I have however found several posts (steam and subsim) indicating that SH3 needs to be run on administrator mode, but more important Win XP sp2, and those guys have the same symptoms I am having. I'm also reinstalling GWX 3.0 as the FullSingleInstaller which people seem to use more, as I used the 7part file installer before. Just gonna shotgun all these ideas, and hope one of em works.
LuteFlute is offline   Reply With Quote
Old 03-16-2021, 06:30 PM   #8
LuteFlute
Watch
 
Join Date: Mar 2021
Location: Philippines
Posts: 17
Downloads: 43
Uploads: 0
Default

Quote:
Originally Posted by Aktungbby View Post
LuteFlute!
Thanks Aktungbby!
LuteFlute is offline   Reply With Quote
Old 03-16-2021, 06:32 PM   #9
Jeff-Groves
Village Idiot
 
Jeff-Groves's Avatar
 
Join Date: Sep 2014
Location: Nevada, Ohio
Posts: 4,496
Downloads: 104
Uploads: 0


Default

The Steam install seems to be causing a lot of trouble as of late.
I don't use Steam but try to help since I wrote the GWX 3 installer.

I run as WinXP service pack 3

I use Windows 7
__________________
Professional Cunning Linguist
Don't MAKE ME get my Crayons out to draw you a picture!
Jeff-Groves is offline   Reply With Quote
Old 03-16-2021, 06:33 PM   #10
LuteFlute
Watch
 
Join Date: Mar 2021
Location: Philippines
Posts: 17
Downloads: 43
Uploads: 0
Default

Quote:
Originally Posted by Jeff-Groves View Post
The Steam install seems to be causing a lot of trouble as of late.
I don't use Steam but try to help since I wrote the GWX 3 installer.
I'll let you know how things go, as this GWX 3.0 file type is barely being seeded. should be finished in around 1 - 2 hours.
LuteFlute is offline   Reply With Quote
Old 03-16-2021, 06:35 PM   #11
Jeff-Groves
Village Idiot
 
Jeff-Groves's Avatar
 
Join Date: Sep 2014
Location: Nevada, Ohio
Posts: 4,496
Downloads: 104
Uploads: 0


Default

This is the FULL install directly from the one who wrote it!
https://www.mediafire.com/file/a0w34..._Full.exe/file

__________________
Professional Cunning Linguist
Don't MAKE ME get my Crayons out to draw you a picture!
Jeff-Groves is offline   Reply With Quote
Old 03-16-2021, 06:38 PM   #12
LuteFlute
Watch
 
Join Date: Mar 2021
Location: Philippines
Posts: 17
Downloads: 43
Uploads: 0
Default

There's too many versions from too many places, I'm currently just downloading the one labeled "GWX3.fullsingleinstallexe.torrent" from http://www.thegreywolves.com/downloads/
LuteFlute is offline   Reply With Quote
Old 03-16-2021, 06:39 PM   #13
Jeff-Groves
Village Idiot
 
Jeff-Groves's Avatar
 
Join Date: Sep 2014
Location: Nevada, Ohio
Posts: 4,496
Downloads: 104
Uploads: 0


Default

Yep. That's a good one.
My link is the ORIGINAL that all copies came from.

You are welcome to ask around about me if you wish.
__________________
Professional Cunning Linguist
Don't MAKE ME get my Crayons out to draw you a picture!
Jeff-Groves is offline   Reply With Quote
Old 03-16-2021, 06:58 PM   #14
John Pancoast
Ocean Warrior
 
Join Date: Apr 2002
Location: Minnysoda
Posts: 3,052
Downloads: 476
Uploads: 4


Default

Jeff will set you straight. Very knowledgable.
__________________
"Realistic" is not always GAME-GOOD." - Wave Skipper
John Pancoast is offline   Reply With Quote
Old 03-16-2021, 07:41 PM   #15
LuteFlute
Watch
 
Join Date: Mar 2021
Location: Philippines
Posts: 17
Downloads: 43
Uploads: 0
Default

I believe you Jeff, not questioning your knowledge or anything, was just remarking as to how over the past 10 years, so many versions of GWX 3.0 have been uploaded to different places, that every other mod I download makes me question if this is the correct one, lol.
LuteFlute is offline   Reply With Quote
Reply

Tags
crashing , ctd , mods

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:26 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright © 1995- 2022 Subsim®
"Subsim" is a registered trademark, all rights reserved.