SUBSIM Radio Room Forums


SUBSIM: The Web's #1 BBS for all submarine and naval simulations since 1997

Go Back   SUBSIM Radio Room Forums > Modern-Era Subsims > Dangerous Waters plus New Developments
Forget password? Reset here

Reply
 
Thread Tools Display Modes
Old 07-31-2019, 10:55 AM   #1
A-Ganger
Helmsman
 
Join Date: Jul 2017
Posts: 106
Downloads: 7
Uploads: 0
Default Ownship Sound

I can see in the controller.ini, for example, this entry below;


Does anyone know how the dllsound item functions in this file? What I want to get rid of is the ownship sound, as it's annoying as all hell and of course completely inaccurate as you don't hear that crap underway.



You can't turn it down in the settings, and I can't figure out how the .ini sets the sound.

[Interface] "688" 1
[BitmapName] "688_US.jpg"
[DLL] "ShipControl.DLL" "X000Y000.bmp" 578 6
[DLL] "SonarBB.DLL" "X035Y000.bmp" 687 7
[DLL] "SonarNB.DLL" "NOLINK"
[DLL] "SonarDemon.DLL" "NOLINK"
[DLL] "SonarActive.DLL" "NOLINK"
[DLL] "SonarIncpt.DLL" "NOLINK"
[DLL] "SonarSSP.DLL" "NOLINK"
[DLL] "Radar.DLL" "X000Y035.bmp" 681 8
[DLL] "Radio.DLL" "X035Y035.bmp" 682 9
[Nav] "X000Y140.bmp" 12
[DLL] "FCTD.DLL" "X035Y070.bmp" 683 11
[DLL] "FCLP.DLL" "NOLINK"
[DLL] "FCINV.DLL" "NOLINK"
[DLL] "TMA.DLL" "X000Y070.bmp" 684 10
[DLL] "Periscope.DLL" "X035Y105.bmp" 686 13
[DLL] "IceTV.DLL" "NOLINK"
[DLL] "Stadimeter.DLL" "NOLINK"
[DLL] "SailBridge.DLL" "X000Y105.bmp" 685 653
;/// soundEngineHum sndtype (none = 0, full=1, full no os =2, muted=3, muted no ownship=4) truthmode
[DLLSOUND] 0 1 1
[NULL] "X035Y140.bmp"
[TEXTDLL] "Text"
[RECO] "VoiceReco.DLL"
[MSLOADOUT] "FCTD.DLL"
[Color] "0,250,89"
[Color] "45,172,91"
[Color] "43,43,43"
[Color] "255,125,0"
[Color] "150,85,22"
[Color] "45,45,45"
[Color] "0,250,89"
[Color] "0,250,89"
[Color] "255,125,0"
[Color] "80,80,80"
[Color] "255,255,220"
[Color] "80,80,80"
[Units] "0"
[MenuImage] "688I_menu.bmp"
[MenuPos] "-11.0,-8.9,-62.0"
[END]
A-Ganger is offline   Reply With Quote
Old 08-02-2019, 06:10 AM   #2
Pirate
Officer
 
Join Date: Sep 2003
Location: Oeiras, PORTUGAL
Posts: 247
Downloads: 131
Uploads: 0
Default

Just look at it like this:
[DLLSOUND] soundEngineHum sndtype truthmode

- soundEngineHum: false = 0, true = 1
- sndtype (3D sound): none = 0, full = 1, full no os = 2, muted = 3, muted no ownship = 4
- truthmode (3D sound): false = 0, true = 1

[DLLSOUND] affects the previous [DLL] item.

If you want to get rid of the ownship sound, maybe setting soundEngineHum to 0 (false) on each DLL is what you need:
[DLLSOUND] 0 0 0
__________________

Last edited by Pirate; 08-02-2019 at 06:20 AM.
Pirate is offline   Reply With Quote
Old 08-11-2019, 05:17 AM   #3
johan_d
Captain
 
Join Date: Jul 2006
Location: The Netherlands
Posts: 547
Downloads: 98
Uploads: 1
Default

I find it annoying too.. maybe replace it with something else ?


Tried 0 3 1, is much more quiete. Thanks!

Last edited by johan_d; 08-11-2019 at 05:26 AM.
johan_d is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:05 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 1995- 2019 Subsim