SUBSIM Radio Room Forums

SUBSIM Radio Room Forums (https://www.subsim.com/radioroom/index.php)
-   Battleship Command (https://www.subsim.com/radioroom/forumdisplay.php?f=319)
-   -   Demo v2.0 release (https://www.subsim.com/radioroom/showthread.php?t=244835)

bracer 04-26-2020 05:12 PM

Demo v2.0 release
 
Hi everyone!

Ever dreamt about taking command of a 38.000 ton battleship, packed with heavy guns that can send 9 rounds (with the weight of 4 cars) over 35kms away at other ships?
Yeah, so do I! That's why I started this hobby project.

I think it is time to release a little tech demo, where you can try out my current progress.
There is plenty of room for improvements as you'll notice, but I think it still is quite enjoyable.

Simply download and extract at your prefered directory and launch the program file to play.
Loading times are slow:
40s to start after clicking the icon.
2mins to load the first mission (LIGHT DEMO)
3mins to load the first mission (SUPPORTER DEMO)
Whatever mission you load afterwards just take seconds, because all resources are loaded at the first mission you launch.
It uses around 6gb of RAM.

It's built in 1920x1080 resolution, so there might be odd stuff in other res.
Please let me know what you find if playing with anything but 1920x1080.

Dowload the "light demo" here:
https://www.dropbox.com/s/f5y35u6jvp...light.zip?dl=0

For the supporter demo you need to be a Patreon, it has a few bonus scenarios:
https://www.patreon.com/battleshipcommand

Press F1 key for help while ingame.
There is no mission endings, simply press ESC when you are finished playing.

https://www.youtube.com/watch?v=xFcUxRyTFcQ

:salute:

johnbla 06-14-2020 09:49 PM

Downloaded the lite version, double click exe and nothing happens!

bracer 06-15-2020 02:54 AM

Quote:

Originally Posted by johnbla (Post 2677822)
Downloaded the lite version, double click exe and nothing happens!


It can take 40s for it to start, have you tried waiting a minute?

Have you downloaded and extracted all the files and launch the exe from inside the folder?


If yes to both questions, what is your specs?

johnbla 06-16-2020 07:29 AM

Yes to both questions. Re downloaded to no effect.

Win 10, i7 - 6700K, 16GB DDR, RTX 2060.

Thanks.

HobbitJack 06-22-2020 09:44 PM

I'm sadly having the same problem.
I'm in a laptop with an I-7 8750 and a 1060.

Cheers!

bracer 06-23-2020 04:10 AM

Hey mates!

I am looking into it.

Should not anything but a mistake as I packed it.


All times are GMT -5. The time now is 07:38 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright 1995- 2021 Subsim®
"Subsim" is a registered trademark, all rights reserved.