SUBSIM Radio Room Forums

SUBSIM Radio Room Forums (https://www.subsim.com/radioroom/index.php)
-   SH4 ATO Mods (https://www.subsim.com/radioroom/forumdisplay.php?f=234)
-   -   blacked out king george v battleship (https://www.subsim.com/radioroom/showthread.php?t=197155)

Webster 07-24-2012 11:43 AM

blacked out king george v battleship
 
im playing the stock game with no mods other then the german mission pack
i was playing the german convoy catastrophe mission and after atacking the convoy i went to the nearby port and noticed the king george battleship there was blacked out and had no skin except for the guns when it randomly appears in the port. its at the rear side of the port near land.

im guessing it must be somehow related to which year version shows up in the game since another german mission that is made for a king george v battleship to show up shows it displayed correctly with a proper skin.

i dont play the german side much so i never noticed this before and was wondering if its just a missing image file or is it a file pathway issue?

if this is indeed a bug i would like to fix it but it would help if someone else can confirm seeing it and knew the circumstances under which it shows up blacked out so i can set it up for testing a fix.



http://i1076.photobucket.com/albums/...120323_030.jpg





http://i1076.photobucket.com/albums/...120225_592.jpg

Webster 07-25-2012 12:16 AM

ok so no one here at this forum plays the german side of the game then :06:

Sailor Steve 07-25-2012 09:25 AM

I do, but I've never seen anything like that. Actually I have, but it was several years ago on the Pacific side. Sorry, I have no idea what to do about it.

Webster 07-25-2012 12:12 PM

if you play the syxx killer missions the convoy catastrophe and skip the convoy and sail to the harbor and its randomely generated by the game as harbor shipping so its not there every time but 2 out of 5 times you will see this black king george on the back side docks.

not sure if it could be an issue with the ship or possibly a harbor setting is off in the settings of what to generate, every time i have seen it out on the water in missins it looks ok

now i did notice the north carolina BB will literally "pop" and dissappear when hit with 1 torpedo so i guess there is something wrong with its damage settings.

when i first did GFO and even still to this day, i couldnt get anyone to give any info on problems or issues with the german side of the game and i dont play that side so i never got a chance to address anything for it in my mod

Tempest555 07-26-2012 01:01 AM

I ran into this problem with 2 different CFG files in the Roster file. One-I couldn't solve-the early model Mogami Heavy Cruiser RSRD. Just like you you see the turrets -but no ship-just black. Another was a Japanese Frieghter I put in the game by converting a SH3 ship. The problem was in the Maru's CFG file (again in the Roster file) and didn't have the dates right. By way of illustration below this is the SH3 ship files cfg I put in to SH4 (still working on the damage model). S01b is a English ore carrier. Anyway look at the dates in red. See if there are no conflicts in your CFG. Like Mogami -KGV has sister ships coming and going in different times in the war (one gets sunk in real life) and there may be a conflict with several vessels dates- Backup the KGV CFG file in Rosterand just leave one ship KGV battleship in it and make all the dates match-If that doesn't work. I have no idea what could be causing it.


[UnitClass]
ClassName=S01B
UnitType=102
AppearanceDate=19380101
DisappearanceDate=19451201

DisplayName=Coastal Freighter Maru


[Texture 1]
TextureName=data/Sea/S01B_/S01B__T01.tga
TextureName=data/Sea/S01B_/S01B__T02.tga
TextureName=data/Sea/S01B_/S01B__T03.tga
LightmapTextureName=data/Sea/S01B_/S01B__O01.tga


StartDate=19380101
EndDate=19451201

Frequency=1

[Unit 1]
Name=Coastal Freighter Maru 01
DOC=19380101
DOD=19451201

Webster 07-29-2012 01:34 PM

hmmm :hmmm:

will try looking into those.

the strange thing is that so far the ships that are on the water are all ok its just this one instance of an AI generated ship in port that i found to have an issue

Tempest555 07-29-2012 02:35 PM

Well I solved my MOGAMI problem and you may want to look into this solution.
I hacked in the RSRD Mogami Cruiser into my SH4 1.5 TMO because I wanted the all 5 turret MOGMAI-class cruiser. But no matter I did that vessel showed up black in the museum but with the turrets showing properly like the KGV in your game. No amount of editting in the cfg files with dates and names worked.
Hmmm that was weird.:hmm2:
So I went through all the files in RSRD Mod file and in TEXTURE files (low and normal) and there were T01's and O01's files for Mogami!! So I copied them into my TEXTURE files and lo and behold it worked. I didn't delete any texture files in the SHIP files-essential I have the same sets of T01 & T01_lr and O01 & O01_lr files in the Mogami SHIP file and TEXTURE files in DATA. Why this works-who knows-but it worked.
{as an aside the funnel cap and top conning tower was black in my hacked Mogami-I copied in the T01's and O01's files for Mogami 2 [this is the plane carrier varient] from RSRD and all of the ship looks normal in Mogami.
Weird.

My 2 cents and FWIW-copy the T01's and O01's for your British battleship into the DATA/TEXTURE files and see what happens.

Webster 07-29-2012 04:30 PM

well i did see it had T01 and T02_lr files and O01 and O02 files but no T02 files so i created the T02 and T02_lr files for it but it didnt seam to matter for what i was seeing.

all other ships in the game need a matching number file so if you have a O02 or 3 then you need TO 2 or 3 matching files in hi and low res for it so maybe somewhere else in the game those missing files are needed.

i got isues with my computer so i had to format and start over so i lost all my research on it up to this point, guess i'll have to start over on this after i get everything reloaded :/\\!!

Tempest555 07-29-2012 04:51 PM

Sorry to hear that. It can be aggravating.


All times are GMT -5. The time now is 03:56 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 1995- 2020 Subsim