SUBSIM Radio Room Forums

SUBSIM Radio Room Forums (
-   SH4 U-Boat Missions Add On (
-   -   [TEC] Virus or something? (

Sniper297 05-17-2017 05:57 PM

Virus or something?

Had a crash playing 1.5, after rebooting I had lost my internet connection. Ran a virus scan but no joy there, so I did a system restore and got one of those irritating \Foldername(2) screwups for every folder and subfolder on my F drive. Fixing that is like trying to get milk from a male ostrich, so I deleted the whole smash and copied the original SH3 1.5 from the C disk and got this message. Went back to the C disk and ran it from that, same message. The system restore point most recent backup was from April, before I downloaded and installed the amazon downloader and u-boat expansion, could this be a problem with copy protection? Anybody ever seen this one? Doesn't affect any of the 1.4 copies I have, those still work fine.

propbeanie 05-17-2017 06:23 PM

If a scan with good stuff didn't find a virus, then it's Windows. For some odd reason, even after all these years, Windows has a nasty habit of trashing its "Hive", or what they used to call the Registry. It's ~huge~ now, and has a bunch of inter-dependecies, and one of those being buggered can trash the whole system, or a drive that it was accessing at the time of the crash. Not cool. Vista used to be the worst about that, even trashing itself during an "update". Now that MS has "patched" their OS (not yours, theirs) from Wannacry, they may well have locked something of vital importance to a restore. Someone else on SubSim can't access their SH5. I haven't gotten to my "real" computer to check mine just yet... Do you have a back-up of your data? It is a painful thing to have to deal with, whether you try to fix the issue, or just blow it all away and try to re-install it all... Sorry man, I definitely feel the pain.

All that said, I've gotten similar error messages when I've had a crash and / or re-installed, and it comes from MultiSH4, and/or LAA. There is a "FileManager.dll" in the root SH4 directory, and if MultiSH4 doesn't recognize it, you'll get a similar message, though it's usually a smaller window than what you have there, and is worded slightly different...

Sniper297 05-17-2017 07:39 PM

Apparently it was common a few years back, found questions with no answers;

I suspect the install had some registry keys which are now missing due to the the system restore, but before going through all that aggravation with amazon downloader again I wanted to see if someone had an easier way.

propbeanie 05-17-2017 07:46 PM

The Amazon download used to let you download the actual package, which could then be burned to a disk. Do they still do that, or are they like Steam, and you download the installer, which then downloads and installs the game?

Is the rest of your computer OK? Just SH4 with the issue?

Sniper297 05-17-2017 10:24 PM

Yeah, SH4 1.5 was the only thing affected. When I bought the 1.5 patch I tried to download from the original link several times and it failed every time, then I found the link for the amazon downloader and got that instead. That worked, but instead of the usual window with the option to browse it just installed it in program files\ubisoft. Hang on, let me run a REGEDIT.

Yep, search for "silent" turns up registry keys for C:\Program Files (Win XP, no X86) etc.etc SH4.exe and S3D.exe. No files no backup, the downloader just checks the registry and installs without asking where the user wants it. After that I was able to copy the folder to three different subfolders on my F drive (SANDISK SSD) and they all ran okay until the crash/system restore.

Again this is not the first time in history, the google search turns up the same error message on several websites.

propbeanie 05-17-2017 11:09 PM

Well, temporarily turn off the LAA, and if you're using MultiSH4, make sure you've got v2.6 of it. Copy your current Save folder just in case it works later, but delete the original (whether you have MultiSH4 or not). Run MultiSH4 again and make a new folder. Re-enable the LAA, and see if SH4 will start back up. When my install did that last time, all my error box said was "Invalid version of FileManager detected. MultiSH4 will stop - OK", so yours is definitely different, and it sounds like something is written somewhere that's pointing at a bad memory location in the game's allocation for that texture file...

Sniper297 05-18-2017 12:55 PM

If "LAA" has something to do with anti aliasing, I have AA and anisotropic filtering off globally, everything set for max framerates. I doubt that would be a factor if the little culprit fails on launch anyway. MultiSH4 was one of my early suspects, I eliminated that as a possible cause by testing in a virgin install that doesn't have anything in it.

Amazon downloader is probably not the cause either;

That's a STEAM version with the same problem.

propbeanie 05-18-2017 01:56 PM

LAA is that Large Address Aware thingie. Sometimes if there's changes to the executable, MultiSH4 throws an error somewhat similar to what you're getting, but I don't think that's it. The crash trashed something on you, and it may not be worth the aggravation to try to figure out what it was. If you can start with RR's SH4CMS (which I've been mis-naming lately as "Crash Management System", but it's actually "Corruption") it's relatively easy to restore, but setting it up takes some extra work beyond just a straight-up install... Chalk it up to another computer-slash-ubisoft-slash-whatever kind of problem that most likely will not have a easy resolution.

Sniper297 05-18-2017 02:23 PM

Windows XP media edition, 2 gigs RAM, no large address aware thingamy. :D

Actually the simplest way - but most time consuming - is to start over from scratch, unzip the 1.4 backup, delete the program files\ubisoft folder, replace with the original unmodified (contains no artificial sweeteners or preservatives) SH4 1.4, then hunt up the amazon thing and reinstall 1.5.

As for multiSH4, it may or may not be responsible for more frequent crashes, but since I never installed it in the original patched to 1.5 version - in fact not even on the same disk, the only place I used multiSH4 was on the F drive - it's unlikely to have affected the original in any way. In fact I never actually played the original until recent testing, back in 2007 I copied the folder to a different location before I even tried the game.

All times are GMT -5. The time now is 09:05 PM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 1995- 2020 Subsim