SUBSIM Radio Room Forums

SUBSIM Radio Room Forums (https://www.subsim.com/radioroom/index.php)
-   SH4 Mods Workshop (https://www.subsim.com/radioroom/forumdisplay.php?f=219)
-   -   [REL] FOTRS Ultimate Project (https://www.subsim.com/radioroom/showthread.php?t=226270)

cdrsubron7 05-28-2016 07:38 PM

Some Of My Thoughts
 
OK, I've got FOTRS v1.3 loaded and ready to play. First thing I've done is check max-peck's mod Razzle-Dazzle (I coined a Japanese name called Kamafuraju Maru, but it's his choice). Some screenies from June, '44 using v1.3.

http://i65.tinypic.com/29zspbc.jpg

http://i68.tinypic.com/14tpqmv.jpg

http://i65.tinypic.com/j638md.jpg

Now something that definitely needs to be improved and brought up to TMO standards. As you can see by the picture below the fire on a damaged ship looks so v1.0. I much prefer the TMO look.

FOTRS v1.3

http://i67.tinypic.com/2ynhy1g.jpg

TMO v2.5

http://i63.tinypic.com/260acdt.jpg

XTBilly

I can't confirm the ticking noises you've reported just using v1.3. Unfortunately, I don't don't know how too merge the sound files from v2.0 2ith v1.3. Contact me via PM and give me a crash course. Just a random thought, could it be a difference between sound cards? I'm using a Creative SB Z card. What kind of sound card arte using on your computer?

Rockin Robbins 05-28-2016 08:20 PM

Well, the FOTRS version of the fire sure is a lot more realistic. Oil fires are black and smoky. not bright and red.

cdrsubron7 05-28-2016 08:37 PM

Quote:

Originally Posted by Rockin Robbins (Post 2407874)
Well, the FOTRS version of the fire sure is a lot more realistic. Oil fires are black and smoky. not bright and red.

I guess it's a matter of taste, right RR? :yeah:

Rockin Robbins 05-28-2016 08:51 PM

That's why I envision guaranteed compatible mod plugins for things like fire, smoke, AI, plotting schemes {already done), possibly sounds... Many things usually hard-coded by modders can be user choice - - cafeteria style. The aim would be that the player plays like he wants to, not necessarily the way we would require of them.

I'll always remember when Lurker decided he hated Ducimus' evil airplanes that could bomb you when you're submerged. Next thing you know TMO "compatible" RSRD stomped all over them, eliminating Duci's vision of his mod. I promise I'll never do something like that., Maddy's vision of the mod is what it will be in the default installation with user customization provided in. many areas. In fact, as many areas as possible

Love your screen shots. They help a lot for accurate communication.

cdrsubron7 05-28-2016 08:56 PM

Quote:

Originally Posted by Rockin Robbins (Post 2407884)
That's why I envision guaranteed compatible mod plugins for things like fire, smoke, AI, plotting schemes {already done), possibly sounds... Many things usually hard-coded by modders can be user choice - - cafeteria style. The aim would be that the player plays like he wants to, not necessarily the way we would require of them.

I'll always remember when Lurker decided he hated Ducimus' evil airplanes that could bomb you when you're submerged. Next thing you know TMO "compatible" RSRD stomped all over them, eliminating Duci's vision of his mod. I promise I'll never do something like that.


Sounds like you've got a plan to work with, RR. i wasn't trying to change anything just venting something about FOTRS v1.3 that bugged somewhat. :D

fitzcarraldo 05-28-2016 10:48 PM

I use a modified version of Poul Sounds in my FOTRS v13. A combination of Poul's and Pacific Sound Mod.

Warning with transferring warships from v2. It's needed to know ALL the files involved. I have a lot of CTDs with it. No problems with textures.

Also it is possible transfer merchants from OM to FOTRS. I did it successfully. Only merchants. No scripting needed for merchants.

Regards and in contact.

Fitzcarraldo :salute:

XTBilly 05-29-2016 03:09 AM

FOTRS v2.0 sound
 
I confirm that the new v2.0 sounds are working correctly on v1.3.

I uploaded a JSGME ready module for everyone to enjoy and test.
Use this link:

Edit: Maybe this link works...
https://www.mediafire.com/folder/pf4...xkcs/Documents

Instructions:
1. Unzip the .rar file to a temporary folder.
2. Copy the folder contents to SH4\MODS folder.
3. Enable with JSGME.
4. Ignore the JSGME warning and overwrite everything when asked.

Rockin Robbins 05-29-2016 07:41 AM

Quote:

Originally Posted by XTBilly (Post 2407906)
I confirm that the new v2.0 sounds are working correctly on v1.3.

I uploaded a JSGME ready module for everyone to enjoy and test.
Use this link:

https://www.mediafire.com/#pf407cxjqxkcs

And I get the MediaFire splash page with no download. Billy and I are going to test my shared Google Drive folder to see if he can save files there. If it works I'll just collect e-mail addresses and you can all have edit rights there. We can also link files there for posts here in the thread.

propbeanie 05-29-2016 10:25 AM

Quote:

Originally Posted by XTBilly (Post 2407784)
... The bad is that the ghost of ticking sound haunts me again. I located where the problem is. The creaking sounds when underwater. With v2.o sounds running, the program tries to play a creaking sound every 2-3 seconds, making the game unplayable...

Does anyone else experience this situation?...

Give me some feedback, please.

OK, while I've accidentally trashed my v1.3 install (my mistake), I think I've discovered what the sound is supposed to be, and I can get it to sound in v1.3 ("standard" FOTRSv1.3 sounds) when going beyond "Test Depth" in a Gar boat (330 feet). Once you go a bit beyond the red line, there will be the sound of glass breaking, which I assume is supposed to be the sound of a meter's faceplate glass breaking, maybe a light bulb... Problem is, the deeper you go, the more glass that breaks, to the point that by the time you reach approx. 360+ feet, the glass breaking sounds every 1-2 seconds, and is very irritating, in that it's the same sound, at the same volume, and is much louder than the creaking sounds, which have basically stopped anyway. The version 2 sound files may not have a "breaking glass" sound, and that might be the "click" that you're hearing, which would be a file failing to load or play... maybe. But it's much more irritating actually hearing the sound in v1.3... :wink:

Now, if I can figure out what I did to deserve the odd eyes "in" my crewmen... they're there, just very disturbing looking. I trashed something. I also have blank dials at the control station. Maybe it's from going beyond test depth... ?? :haha:

Edit: In my "stock" v1.5 SH4 install, I've gone much deeper than red line in a Gar boat, and the creaking never stops, no breaking glass sound, and cruised around just fine at 430 feet. I have not attempted to find what happens and at what depth the actual "crush" is yet.

cdrsubron7 05-29-2016 11:22 AM

After setting up and testing the sound folder from v2.0 in v1.3. I didn't hear the creaking noises on all sub classes. The ones I did hear it in was the Sargo, Tambor, Gar, and Gato. Heard nothing while diving or coming back to PD. Just wondering if the sound of the creaking is intermittent or is it something that should happen during each dive? Other than that when installing I overwrote when asked by the JSGME and everything else seems to work fine. Can't say I've heard this ticking noise you've mentioned Billy.

One question. The background music plays all the time, is there a way to shorten the duration of it so it does not play all the time.

XTBilly 05-29-2016 11:30 AM

Quote:

Originally Posted by propbeanie (Post 2408010)
OK, while I've accidentally trashed my v1.3 install (my mistake), I think I've discovered what the sound is supposed to be, and I can get it to sound in v1.3 ("standard" FOTRSv1.3 sounds) when going beyond "Test Depth" in a Gar boat (330 feet). Once you go a bit beyond the red line, there will be the sound of glass breaking, which I assume is supposed to be the sound of a meter's faceplate glass breaking, maybe a light bulb... Problem is, the deeper you go, the more glass that breaks, to the point that by the time you reach approx. 360+ feet, the glass breaking sounds every 1-2 seconds, and is very irritating, in that it's the same sound, at the same volume, and is much louder than the creaking sounds, which have basically stopped anyway. The version 2 sound files may not have a "breaking glass" sound, and that might be the "click" that you're hearing, which would be a file failing to load or play... maybe. But it's much more irritating actually hearing the sound in v1.3... :wink:

Now, if I can figure out what I did to deserve the odd eyes "in" my crewmen... they're there, just very disturbing looking. I trashed something. I also have blank dials at the control station. Maybe it's from going beyond test depth... ?? :haha:

Edit: In my "stock" v1.5 SH4 install, I've gone much deeper than red line in a Gar boat, and the creaking never stops, no breaking glass sound, and cruised around just fine at 430 feet. I have not attempted to find what happens and at what depth the actual "crush" is yet.

Hahaha!! You're killing me mate!:haha:

But no, it's not the glass breaking sound I hear. In my 2 computers the game is trying to play a creaking sound, the sound starts, and in 2-3 seconds the sound starts again, and again and again...

It seems that I'm the only one experiencing this, so, I deleted the 4 creaking sounds and finally got piece of mind.:smug:

The maximum depth I'm diving is about 20 feet higher than the depth glasses start to break. But dear God! 430ft in the Gar...:o
Good thing you're still alive to tell the story!:)
PS.

[Spam mode on]
Edgar Allan Poe is one of my beloved writers. Second only to H.P.Lovecraft.:p2:
[Spam mode off]

XTBilly 05-29-2016 11:51 AM

Quote:

Originally Posted by cdrsubron7 (Post 2408048)
After setting up and testing the sound folder from v2.0 in v1.3. I didn't hear the creaking noises on all sub classes. The ones I did hear it in was the Sargo, Tambor, Gar, and Gato. Heard nothing while diving or coming back to PD. Just wondering if the sound of the creaking is intermittent or is it something that should happen during each dive? Other than that when installing I overwrote when asked by the JSGME and everything else seems to work fine. Can't say I've heard this ticking noise you've mentioned Billy.

One question. The background music plays all the time, is there a way to shorten the duration of it so it does not play all the time.

Thanks for the feedback!:up:
Strange, I had creaking noises on all the subs except the pigboat. On my wife's laptop even the pigboat had creaking noises. I cannot explain that...
I actually deleted them, the noise was continuous and was breaking my nerves. But I miss them. I'll put them back and experiment further.:O:

The beauty of FOTRS... Balao class. Headphones at 100%. Ship sighted! Two sampans. About an hour (game time) after sinking them, radar contact! Ahead flank, intercepting course, a Kagero and a subchaser!:o Sighted at 9000 yards. Spotted me of course. Crash dive, 540ft deep, got depth charged. No damage, the level 4 creaking sound starts to play! Man, that was scary!! Returned immediately to 400 feet!:har:

Edit:
SH4's music is great. I have the Collector's Edition, with the game's music on CD.
But when the action starts, I press Escape, options, sound, untick the music button:har:

propbeanie 05-29-2016 12:17 PM

Quote:

Originally Posted by XTBilly (Post 2408052)
... the game is trying to play a creaking sound, the sound starts, and in 2-3 seconds the sound starts again, and again and again...

It seems that I'm the only one experiencing this, so, I deleted the 4 creaking sounds and finally got piece of mind.:smug:

The maximum depth I'm diving is about 20 feet higher than the depth glasses start to break. But dear God! 430ft in the Gar...:o
Good thing you're still alive to tell the story!:)
PS.

[Spam mode on]
Edgar Allan Poe is one of my beloved writers. Second only to H.P.Lovecraft.:p2:
[Spam mode off]

Ah yesh... H.P.Lovecraft - I love his version of "frogmen"... *spooky*!

As for the Gar in stock v1.5 SH4, at 430 feet, well, 42+ minutes at 440, cruising East off of Mindanao, started taking "Hull damage, Sir!" every few minutes, then the "Medic!", "Forward Torpedo Room Destroyed, Sir!", etc., etc., coming ever faster, until the room starts spinning, fade to black, then the look at the sky & the ocean as it fades to "Mission Failed, sub destroyed", "creaking" sound the whole time, but never once got a glass breaking sound. Same boat, same depth, same sequence of events in FOTRS v1.3, other than no creaking, and the incessant glass breaking, with perhaps a sped up death spiral, by maybe 10 minutes...

I am in the process now of un-installing, cleaning up, and then doing a "clean" re-install of SH4 1.5 CE to my computer, and use only the files found on SumSim, download links courtesy of Rockin Robbins in posting #30 . More later, and I'll try the v2 sounds again, and see if I can get what you got.

Rockin Robbins 05-29-2016 03:17 PM

XTBilly and I are checking out a shared Google Drive folder to see if we can all collaborate in the same disk drive that all can access. I have Billy's FOTRS 2.0 sound mod there now, along with a bunch of stuff I took from propbeanie's link http://www.aotd.de/FOTRS/ in post #22. All the good sound stuff there was in FOTRS 2.0.

As soon as XTBilly says he's golden and can save, edit and load files from the shared directory then we'll go live to everyone on the thread.

cdrsubron7 05-29-2016 05:00 PM

Hey RR

A number of years ago I made a small mod which I use anytime that I make a new install of SH4. What the mod does is change the tonnage of the Japanese warships to more realistic values of the actual ships in IJN during WW II. If you like to use it with the FOTRS Ultimate mod I'll supply a copy of it for you. Just the thought :D :up:


All times are GMT -5. The time now is 05:49 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 1995- 2019 Subsim