SUBSIM Radio Room Forums
The newest naval sim by Totem Games!

SUBSIM: The Web's #1 BBS for all submarine and naval simulations since 1997

Go Back   SUBSIM Radio Room Forums > Silent Hunter 3 - 4 - 5 > SH4 Fleet Boat Mods Workshop
Forget password? Reset here

Reply
 
Thread Tools Display Modes
Old 07-22-2017, 10:16 PM   #5071
propbeanie
CTD Überbringer
 
propbeanie's Avatar
 
Join Date: May 2016
Location: The Crossroads of Mid-America
Posts: 2,195
Downloads: 162
Uploads: 0


Default

Quote:
Originally Posted by jenrick View Post
Maybe I'm just dense, but could someone post the steps to install FOTRS on a clean install of SH4 with JGME? I'm having no success and it keeps crashing out.

-Jenrick
Once you get the hang of JSGME, it's a breeze... ee-yeah, right...

It's advisable to empty the My Documents \ SH4 folder. Make your SH4 install. Therein lies the rub. The game disk, or download, or Steam game, all default to using "C:\ Program Files (x86) \ ..." as their "base" folder to install to. This is a left-over from the Windows XP days, when that was fine to do. With today's "modern" computer and "security", Windows will "protect" that folder, and prevent "un-authorized" changes, thereby wrecking your mod activations, since you didn't go through Windows to do that. So create a folder yourself, or edit the path, and stay away from Program Files folders. On my disk installs, I just delete that portion of the path, and have "C:\ Ubisoft \ Silent Hunter Wolves of the Pacific".

Once you have that, put JSGME in the Wolves of the Pacific (or whatever you called it) folder, and run it. JSGME will then create a folder called MODS in that same directory - er, folder. So you'll now see the folders "Data", "MODS", "RegistrationReminder", etc. Take your mod archive file and place it in MODS. If you use 7zip , you're golden. Just activate the mod, as below. If you use the MS Windows archive mis-manager, you'll have an extra folder of "100_FalloftheRisingSun_Ultimate_v0.XX_PublicBeta_ EN" (whatever the version is for the "XX"). You need to change the name of the top-level one, and then "drag" that extra folder out. Delete the one you changed the name of. Now run JSGME and click on "Tasks..." in the middle bar there. Choose "Create snapshot of game files". It will take that a while to run. Once it's finished, then select the "100_FalloftheRisingSun_Ultimate_v0.XX_PublicBeta_ EN" listing in the left-hand pane, and then on the right facing "Arrow" at the top of the center bar, and then find something else to do for a while. Depending on the computer, it might be five, it might be ten minutes... When that's complete, play the game. However, do NOT load any previous saves from any other mods, including FotRSU. Doing so will corrupt your game. Hopefully, that does it for you. Either way, let us know how you get along.
__________________

propbeanie is offline   Reply With Quote
Old 07-23-2017, 07:19 AM   #5072
torpedobait
Captain
 
Join Date: Feb 2004
Location: Kentucky
Posts: 502
Downloads: 326
Uploads: 0
Default

Quote:
Originally Posted by propbeanie View Post
Just to satisfy my curiosity, that convoy when you encountered it, was it OK, or all messed up? If it was messed up, then that would be another issue further down the coast... - Something has trashed the 4Xx_Jap_HarborTraffic layers - and it looks like it's the old Jap_HarborTraffic layer...
No, the convoy was not messed up. They proceeded in an orderly single file, straight ahead, right into my torpedoes (heh, heh).
__________________
TorpedoBait (Damn! Where did that come from?)

Software: Large Address Aware; FOTARS Ultimate v0.63 Public Beta EN, Smart Game Booster 4;
Hardware: Falcon-NW Mach V, Intel(R) Core(TM) i7CPU 975@ 3.33GHz, 12Gb RAM, Win7 Pro 64-bit, NVIDIA GeForce GTX970, Creative SoundBlaster Z.
torpedobait is offline   Reply With Quote
Old 07-23-2017, 09:12 AM   #5073
Larrywb57
Loader
 
Join Date: Dec 2009
Location: NC
Posts: 83
Downloads: 165
Uploads: 0
Default A possible hit and run

First Patrol out of Midway with the USS Plunger, porpoise class submarine, sonar picked up sound contact. Turned to heading of 106° and surfaced at flank speed towards hearing of sound contact. Using free camera, went in the direction of the sound contact. Came across two fishing vessels and proceeded towards sound contact. The convoy appeared to be in a heading of WNW. Noticed what appeared to be a Medium Composite Freighter was sinking with only the bow above the water. The convoy consisted of a total of four other ships. They were being led by a Corvette Kanamuro Class escort, a Tonan Maru Class was next followed by two Medium Cooler Class ship, the last one on a helming course. As I continued to watch, the escort was leading with the other two ships in a straight line behind. The last Medium Cooler ship started moving in a different direction, SSW. The reason I'm calling attention to this is, there 'might' have been a collision of two convoys before I arrived. My position was long 142° 52'E lat 41°46'E. Time was 08:37 hrs, USS Plunger is Midway base submarine. Using FOTRS version 0.63 downloaded on July 22.
__________________
Intel Core 2 duo CPU E6650 @ 2.33 GHz, 2 GB of memory and a Nvidia Geforce 8400GS graphic card. OS Windows 7 32 bit.
Generic Mod Enabler - v2.6.0.157
[C:\Ubisoft\Silent Hunter 4\MODS]

100_FalloftheRisingSun_Ultimate_
v0.63_PublicBeta_EN
Bigger Better Protractors
Larrywb57 is offline   Reply With Quote
Old 07-23-2017, 02:59 PM   #5074
RampantParanoia
Nub
 
Join Date: Oct 2011
Location: Bristol, UK
Posts: 10
Downloads: 34
Uploads: 0
Default

Quote:
Originally Posted by propbeanie View Post
did you "say" earlier what your video card was, and what you're running Windows at, resolution-wise, what the "native" resolution of your monitor is, and what resolution and refresh are you running the game itself at?...
Yeah, now included in my sig for simplicity I've wiped saves and installed 0.63 and it's still doing it through my own sub, with and without V-sync enable and with/without the tweaks from the nVidia thread enabled. I'll have to have a deeper read of it but it's 30-odd pages so will take some time!

Cheers for all your help and patience so far
__________________
Hardware: Asus Rampage II Extreme, Intel Core i7 920 @ 3.8GHz, 12GB RAM, nVidia GTX 1060 6GB, Sound Blaster X-Fi Titanium, Dell 2408WFP
Software: Windows 10 64 bit, Large Address Aware, SH4 CMS (D:\SH4\...), FotRSU Public Beta v0.63 @ 1920x1200x60Hz
RampantParanoia is offline   Reply With Quote
Old 07-23-2017, 03:06 PM   #5075
propbeanie
CTD Überbringer
 
propbeanie's Avatar
 
Join Date: May 2016
Location: The Crossroads of Mid-America
Posts: 2,195
Downloads: 162
Uploads: 0


Default

Quote:
Originally Posted by RampantParanoia View Post
Yeah, now included in my sig for simplicity I've wiped saves and installed 0.63 and it's still doing it through my own sub, with and without V-sync enable and with/without the tweaks from the nVidia thread enabled. I'll have to have a deeper read of it but it's 30-odd pages so will take some time!

Cheers for all your help and patience so far
Are you running everything then at the 1920x1200 @ 60 Hz? Is it possible to try a refresh @ 70Hz and see what it does? Failing there (expected), try disabling one thing at a time in the video settings portion of the game and see what you get. If you want, I can make you a Single Mission, set on a certain date at a certain time in a certain location, so that you can more easily test the results... ?? Let me know what boat you want, and where you want it to be set at.
__________________

propbeanie is offline   Reply With Quote
Old 07-23-2017, 03:09 PM   #5076
propbeanie
CTD Überbringer
 
propbeanie's Avatar
 
Join Date: May 2016
Location: The Crossroads of Mid-America
Posts: 2,195
Downloads: 162
Uploads: 0


Default

Quote:
Originally Posted by Larrywb57 View Post
First Patrol out of Midway with the USS Plunger, porpoise class submarine, sonar picked up sound contact. Turned to heading of 106° and surfaced at flank speed towards hearing of sound contact. Using free camera, went in the direction of the sound contact. Came across two fishing vessels and proceeded towards sound contact. The convoy appeared to be in a heading of WNW. Noticed what appeared to be a Medium Composite Freighter was sinking with only the bow above the water. The convoy consisted of a total of four other ships. They were being led by a Corvette Kanamuro Class escort, a Tonan Maru Class was next followed by two Medium Cooler Class ship, the last one on a helming course. As I continued to watch, the escort was leading with the other two ships in a straight line behind. The last Medium Cooler ship started moving in a different direction, SSW. The reason I'm calling attention to this is, there 'might' have been a collision of two convoys before I arrived. My position was long 142° 52'E lat 41°46'E. Time was 08:37 hrs, USS Plunger is Midway base submarine. Using FOTRS version 0.63 downloaded on July 22.
I'm taking it then that you left from Midway on Dec 8, 1941? I'm not so worried that a convoy collided with another, as much as I am about the harbors getting choked with wrecks, but it still deserves to be looked at, and try to minimize it if we can. Thanks...
__________________

propbeanie is offline   Reply With Quote
Old 07-23-2017, 10:25 PM   #5077
Larrywb57
Loader
 
Join Date: Dec 2009
Location: NC
Posts: 83
Downloads: 165
Uploads: 0
Default

Quote:
Originally Posted by propbeanie View Post
I'm taking it then that you left from Midway on Dec 8, 1941? I'm not so worried that a convoy collided with another, as much as I am about the harbors getting choked with wrecks, but it still deserves to be looked at, and try to minimize it if we can. Thanks...
Sorry Propbeanie. I was in a hurry to post the message before I left for work that I didn't include the date & time. It was 18Jun42 at 08:37 hrs.
__________________
Intel Core 2 duo CPU E6650 @ 2.33 GHz, 2 GB of memory and a Nvidia Geforce 8400GS graphic card. OS Windows 7 32 bit.
Generic Mod Enabler - v2.6.0.157
[C:\Ubisoft\Silent Hunter 4\MODS]

100_FalloftheRisingSun_Ultimate_
v0.63_PublicBeta_EN
Bigger Better Protractors
Larrywb57 is offline   Reply With Quote
Old 07-24-2017, 07:17 AM   #5078
torpedobait
Captain
 
Join Date: Feb 2004
Location: Kentucky
Posts: 502
Downloads: 326
Uploads: 0
Default Cool Damage!

In all the years I've been sub simming, I've never see a hit do this kind of damage, where it just blew a chunk out of the whole hull. I've seen holes in many places, but never a chunk. If this is one of the surprises you all built in to FOTARSU, it's great. Notice how the hull above collapsed at the weak point and actually hinged until it broke in two. Just lovely!



__________________
TorpedoBait (Damn! Where did that come from?)

Software: Large Address Aware; FOTARS Ultimate v0.63 Public Beta EN, Smart Game Booster 4;
Hardware: Falcon-NW Mach V, Intel(R) Core(TM) i7CPU 975@ 3.33GHz, 12Gb RAM, Win7 Pro 64-bit, NVIDIA GeForce GTX970, Creative SoundBlaster Z.
torpedobait is offline   Reply With Quote
Old 07-24-2017, 07:55 AM   #5079
propbeanie
CTD Überbringer
 
propbeanie's Avatar
 
Join Date: May 2016
Location: The Crossroads of Mid-America
Posts: 2,195
Downloads: 162
Uploads: 0


Default

I think that's just one of those "critical hit" thingies, but can't say for certain. Some of the tankers break in two separate pieces. They should have a few more able to do that "hinge" style. That is very cool. What's even nicer is when you can see the "insides" of a ship, instead of just a slab of nothingness colored grey, but that takes a lot of artwork to do, and I ain't no artist...
__________________

propbeanie is offline   Reply With Quote
Old 07-24-2017, 08:17 AM   #5080
propbeanie
CTD Überbringer
 
propbeanie's Avatar
 
Join Date: May 2016
Location: The Crossroads of Mid-America
Posts: 2,195
Downloads: 162
Uploads: 0


Default

Quote:
Originally Posted by Larrywb57 View Post
Sorry Propbeanie. I was in a hurry to post the message before I left for work that I didn't include the date & time. It was 18Jun42 at 08:37 hrs.
Thanks for that. Almost all of the levels from 1941 through 1943 are the same in that area, such that with just the Merchants and the Convoys layer loaded, we have this traffic pattern:



Lot's of potential candidates in the area, with a lot of GENERIC calls, so it could be a Merchant group (two ships) encountering a Convoy group (2-8 ships), or two convoys, or whatever. This doesn't even show what's now a messed-up 42a_Jap_HarborTraffic layer, that has magically doubled its traffic in the same area, with a similar number of groups as you see in the grab above. If we get the HarborTraffic layer to behave, it should make it all better... Thanks for the additional info... now, back to work!...
__________________

propbeanie is offline   Reply With Quote
Old 07-24-2017, 10:20 AM   #5081
RampantParanoia
Nub
 
Join Date: Oct 2011
Location: Bristol, UK
Posts: 10
Downloads: 34
Uploads: 0
Default

Quote:
Originally Posted by propbeanie View Post
Are you running everything then at the 1920x1200 @ 60 Hz? Is it possible to try a refresh @ 70Hz and see what it does?
Yeah it's all running at native. My monitor will only do 59 or 60Hz, I'll try 59 just in case. I'll also work my way through the video settings one by one and report back.

Quote:
Originally Posted by propbeanie View Post
If you want, I can make you a Single Mission...
Ta muchly, I have a (fresh) save at sunset I've been using to test, unless there's something in the code that means I'd need to start a fresh mission to properly test everything?
__________________
Hardware: Asus Rampage II Extreme, Intel Core i7 920 @ 3.8GHz, 12GB RAM, nVidia GTX 1060 6GB, Sound Blaster X-Fi Titanium, Dell 2408WFP
Software: Windows 10 64 bit, Large Address Aware, SH4 CMS (D:\SH4\...), FotRSU Public Beta v0.63 @ 1920x1200x60Hz
RampantParanoia is offline   Reply With Quote
Old 07-24-2017, 12:00 PM   #5082
propbeanie
CTD Überbringer
 
propbeanie's Avatar
 
Join Date: May 2016
Location: The Crossroads of Mid-America
Posts: 2,195
Downloads: 162
Uploads: 0


Default

The saves sometimes will pull bad data from the save folder that then "overwrites" what's in the computer memory for the game, not the file you edited. I'm not sure how the Settings screen stuff goes though... seems to me that you're fine, but we'd have to wait for someone more knowledgeable to confirm...
__________________

propbeanie is offline   Reply With Quote
Old 07-25-2017, 08:00 AM   #5083
propbeanie
CTD Überbringer
 
propbeanie's Avatar
 
Join Date: May 2016
Location: The Crossroads of Mid-America
Posts: 2,195
Downloads: 162
Uploads: 0


Default

Re-visiting Miyoka Harbor, I've done an experiment with eliminating the Jap_HarborTraffic.mis from the game by renaming it with a DOT BAK appended to the name, and ran a newly created mission with a Tambor boat sitting just outside the bay's mouth, and got this:








Go figure. Armageddon has been termporarily avoided... the file is commented out in the Campaign.cfg, but it loads somehow. Further experimenting is called for, and we'll eliminate the beast one way or the other...

Edit: Fix finalized and will be submitted for next round of updates... the original segment in Campaign.cfg has been deleted, instead of just being commented-out...
__________________


Last edited by propbeanie; 07-25-2017 at 08:17 PM. Reason: Patent Pending
propbeanie is offline   Reply With Quote
Old 07-26-2017, 10:31 AM   #5084
les green01
American Hero
 
les green01's Avatar
 
Join Date: Jan 2002
Posts: 587
Downloads: 787
Uploads: 0
Default

look like you all been doing a great job keep up the good work
les green01 is online   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:35 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright © 1997- 2017 Subsim