SUBSIM Radio Room Forums
Mods and files for every subsim!

SUBSIM: The Web's #1 BBS for all submarine and naval simulations since 1997

Go Back   SUBSIM Radio Room Forums > Silent Hunter 3 - 4 - 5 > Silent Hunter 4: Wolves of the Pacific > SH4 U-Boat Missions Add On
Forget password? Reset here

Reply
 
Thread Tools Display Modes
Old 03-18-2008, 04:29 AM   #1
WernerSobe
Commodore
 
Join Date: Jul 2006
Posts: 625
Downloads: 5
Uploads: 0
Default CO2 bug anyone else?

Ive got a very annoying bug whith IXD2

Sometimes during the campaig my sub just stops refreshing air on surface. Diving and resurfacing doesnt help... The sad result is my crew suffocates in a matter of few hours.

I use unmoded game with minor personal tweaks.
WernerSobe is offline   Reply With Quote
Old 03-18-2008, 04:49 AM   #2
AkbarGulag
Samurai Navy
 
Join Date: May 2007
Location: cfgdatsimZOMGddstgasns
Posts: 569
Downloads: 20
Uploads: 1
Default

This fun new bug was introduced with 1.5

It can happen to you on fleet boats also.
__________________
"6 days into his patrol, the first enemy ship was spotted... a trawler...

...It was at this point, Captain AkbarGulag realised how green his crew was..."
AkbarGulag is offline   Reply With Quote
Old 03-18-2008, 05:04 AM   #3
WernerSobe
Commodore
 
Join Date: Jul 2006
Posts: 625
Downloads: 5
Uploads: 0
Default

any way around?

It screwed my new carrier attempt for the second time now.
WernerSobe is offline   Reply With Quote
Old 03-18-2008, 05:06 AM   #4
AkbarGulag
Samurai Navy
 
Join Date: May 2007
Location: cfgdatsimZOMGddstgasns
Posts: 569
Downloads: 20
Uploads: 1
Default

I have not been succesful. But some people think re-diving, then saving the game, then re-loading the game and hitting emergency surface works.

I could not say for sure if it does :hmm:
__________________
"6 days into his patrol, the first enemy ship was spotted... a trawler...

...It was at this point, Captain AkbarGulag realised how green his crew was..."
AkbarGulag is offline   Reply With Quote
Old 03-18-2008, 07:23 AM   #5
Rockin Robbins
Navy Seal
 
Join Date: Mar 2007
Location: DeLand, FL
Posts: 8,785
Downloads: 129
Uploads: 53


Default Ruh Roh

Trying weird things now. 35% CO2. When do we all die? I smell a patch on the horizon...
Rockin Robbins is offline   Reply With Quote
Old 03-18-2008, 09:54 PM   #6
gruntington
Swabbie
 
Join Date: Aug 2007
Posts: 14
Downloads: 1
Uploads: 0
Default

I had that bug once. I had to quit out of the game, restart, then load a save game. I was able to continue with oxygen restored.
gruntington is offline   Reply With Quote
Old 03-19-2008, 06:09 AM   #7
Kpt. Lehmann
GWX Project Manager
 
Kpt. Lehmann's Avatar
 
Join Date: Jul 2005
Location: The Republic of Texas
Posts: 6,640
Downloads: 59
Uploads: 0


Default

Quote:
Originally Posted by Rockin Robbins
Trying weird things now. 35% CO2. When do we all die? I smell a patch on the horizon...
Assuming this turns out to be a persistent bug... it certainly warrants the release of a hotfix.
__________________


TheGreyWolves.com
It is better to live a short and meaningful life... than a long and miserable one.
Kpt. Lehmann is offline   Reply With Quote
Old 03-19-2008, 07:07 AM   #8
Rockin Robbins
Navy Seal
 
Join Date: Mar 2007
Location: DeLand, FL
Posts: 8,785
Downloads: 129
Uploads: 53


Confirmed

Saving on the surface and reloading the save fixes the problem. I don't know if it is necessary to quit the game altogether. Sorry, blew the testing procedure there. Still needs a hotfix though.
Rockin Robbins is offline   Reply With Quote
Old 03-19-2008, 09:59 AM   #9
maerean_m
Captain
 
Join Date: Mar 2007
Location: Bucharest, Romania
Posts: 529
Downloads: 0
Uploads: 0
Default

Has anyone experienced the CO2 bug with an unmodded add-on (no modds whatsoever)?
__________________
Kilroy was here
maerean_m is offline   Reply With Quote
Old 03-19-2008, 10:03 AM   #10
AVGWarhawk
Lucky Jack
 
AVGWarhawk's Avatar
 
Join Date: Jun 2005
Location: In a 1954 Buick.
Posts: 26,224
Downloads: 89
Uploads: 0


Default

Only mods I have running in the game are the Draft Mod by Swdw and W_clears enviro mod. I get ths CO2 issue. If I reload the save game it is gone. It is affecting both fleet and uboats alike.
__________________
“You're painfully alive in a drugged and dying culture.”
― Richard Yates, Revolutionary Road
AVGWarhawk is offline   Reply With Quote
Old 03-19-2008, 10:30 AM   #11
maerean_m
Captain
 
Join Date: Mar 2007
Location: Bucharest, Romania
Posts: 529
Downloads: 0
Uploads: 0
Default

The "draft mod" affects only the ships or does it affect the subs?
__________________
Kilroy was here
maerean_m is offline   Reply With Quote
Old 03-19-2008, 10:40 AM   #12
AVGWarhawk
Lucky Jack
 
AVGWarhawk's Avatar
 
Join Date: Jun 2005
Location: In a 1954 Buick.
Posts: 26,224
Downloads: 89
Uploads: 0


Default

The draft mod affects the fleet boats only. It was created before the add-on for the fleet boats. It does not mod the affects of shipping or the uboats drafts.
__________________
“You're painfully alive in a drugged and dying culture.”
― Richard Yates, Revolutionary Road
AVGWarhawk is offline   Reply With Quote
Old 03-19-2008, 10:50 AM   #13
skwasjer
The Old Man
 
Join Date: Apr 2007
Location: Netherlands
Posts: 1,545
Downloads: 25
Uploads: 3
Default

Quote:
Originally Posted by maerean_m
Has anyone experienced the CO2 bug with an unmodded add-on (no modds whatsoever)?
Yes I have once in an unmodded uboat campaign...
skwasjer is offline   Reply With Quote
Old 03-19-2008, 12:47 PM   #14
WhiskeyBravo
Gunner
 
Join Date: Mar 2007
Location: Suffolk, UK
Posts: 96
Downloads: 6
Uploads: 0
Default

Same here, I had the 'not securing from silent running' bug at the same time.

A save/load fixed it and so far it's not happened again.

WB.
WhiskeyBravo is offline   Reply With Quote
Old 03-19-2008, 01:04 PM   #15
brandtryan
Engineer
 
Join Date: Feb 2007
Location: Indianapolis, United States
Posts: 214
Downloads: 122
Uploads: 0
Default

I've experienced this bug as well--though saving and coming back in solves it, as others have said. Unmodded 1.5
brandtryan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:26 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 1995- 2018 Subsim