PDA

View Full Version : Error when running SH4 with Trigger Maru mod


Mousie
03-07-2019, 03:30 PM
I just installed trigger maru, got the mod enabler, ran it, and now it's giving me a few errors

"There is a new (not implemented) page: <PageChooseLoadSave> !
There is a new (not implemented) page: <PageIntelligenceUnits> !
There is new (Not implemented) page <weponsAndSensors> !
Menu ID not found: 0x6101000b!"

Can I get some advice on how to fix them?

propbeanie
03-07-2019, 04:05 PM
Happy Second Posting, Mousie! The errors you show almost look like you are trying to mod an incorrect version of SH4. Did / does the game run fine without TMO enabled? TMO 2.5 was written for SH4 v1.5, which has the Uboat Missions add-on. Do you have a choice for a German career on the Start menu? If you do, which version of TMO do you have? What folder do you have SH4 installed in? :salute:

Mousie
03-07-2019, 04:38 PM
Happy Second Posting, Mousie! The errors you show almost look like you are trying to mod an incorrect version of SH4. Did / does the game run fine without TMO enabled? TMO 2.5 was written for SH4 v1.5, which has the Uboat Missions add-on. Do you have a choice for a German career on the Start menu? If you do, which version of TMO do you have? What folder do you have SH4 installed in? :salute:

I do have the uboat version, that's the "complete edition", right? So yeah, that. The game runs perfectly fine without the mod enabled, and there are the german career at the start menu. I tried it both with launching the regular game, and the uboat version just to double check. The folder it's in is D:\SteamLibrary\steamapps\common\Silent Hunters wolves of the pacific, with the mod in a mods folder inside that directory. I have 2-5

Mousie
03-07-2019, 05:28 PM
Happy Second Posting, Mousie! The errors you show almost look like you are trying to mod an incorrect version of SH4. Did / does the game run fine without TMO enabled? TMO 2.5 was written for SH4 v1.5, which has the Uboat Missions add-on. Do you have a choice for a German career on the Start menu? If you do, which version of TMO do you have? What folder do you have SH4 installed in? :salute:

I think I found what's wrong. The Uboat download is V13, not v1.5. How can I update it?

propbeanie
03-07-2019, 06:07 PM
OK, that explains it then. Someone else on here a few weeks ago had the same problem with telling the difference between their v1.3 and v1.5 Steam installs. It does sound like you are in the v1.3 folder instead of the v1.5 folder. Do you have two "Silent Hunter 4" or "Silent Hunter Wolves of the Pacific" folders under your "common" folder? I have Steam SH3 and SH5, but my SH4 installs are a Ubisoft Gold edition download, a Gold disk, and an original Wolves of the Pacific disk with a Ubisoft purchased download of the Uboat Missions add-on, so I am not familiar with a Steam SH4 install. But I am all-too familiar with dealing with a Steam game install. Let us know what your folder structure is like. :salute: