PDA

View Full Version : No Diesel Engines


ozwally
06-10-2009, 01:40 PM
Hi all,

Just wanting a little help (if its possible to get out of my predicament)

Just launched a surface attack on a massive convoy including some heavy tankers, during heavy fog (had a great time! DD's couldnt spot me most of the time). Eventually though the DD's caught up with me, well 1 in particular, and he attempted to ram me. Luckily I got the engines in full reverse and just grazed his side, then I followed up with a few deck gun shots and managed to get a killing blow. While all this was happening I failed to notice my speed deteriorating slowly, checking damage control I had .25 damage to one diesel and very little to the other (about 0.075). After having the repair crew on it they managed to fix it so its no longer in the damage control list, but I now have no propulsion from them at all. I can use electric engines but the problem is my hull is also damaged so I cant maintain a smooth running depth, and also I cannot recharge my batteries. I'm almost 2k Kilometres from freemantle (my closest port).

Can anyone please help me, I've checked and my crew are in their stations and rested, is there anything I can do to get going again/call for help?

Thanks

Lee

SteamWake
06-10-2009, 02:01 PM
Out of fuel by any chance?

I dont know how to break this to you but it sounds as if that carrer has come to its finale.

Only ways out are to hack or mod the game or go to a previous save. Or start a new carrer.

Sorry to break the bad news. :oops:

ozwally
06-10-2009, 02:08 PM
Thanks for the reply. Had a feeling it was going to come to that :( Got a ton of fuel on board (about 85 - 90). Just wondering whats was up as the engines werent marked as damaged/wrecked/failed etc

Looks like I'll have to go back to a previous save from my last mission, luckily only got 17000 tons from that convoy so not losing alot by it. Hope I can pick up a convoy again in those conditions as it was great, nice to just run at flank through the ships taking them out without DD troubles for the most part!

SteamWake
06-10-2009, 02:42 PM
Double check that the crew isnt at silent running stations or have been left at battle stations for days on end.

The boys get tired.

I know you said there rested but worth takin a look at.

Although the game models two engines and there was really four if you lose any one of them your sol.

There are no 'calls for help' modeled in the game.

Have fun and good luck.

ozwally
06-10-2009, 04:08 PM
Had no joy at all. Everything seems ok. Was trying to just get somewhere on electric motors hoping the diesels would fire up, and eventually the same thing happened to the electric motors, started slowing down then eventually stopped. My sub is stranded

Highbury
06-10-2009, 04:23 PM
Did you try saving it right where you are and re-loading?

It may be a bug of some kind where it is not fully recognizing you are on the surface. I have had that twice recently but not with engines, my CO2 level kept climbing on the surface (but diesels were running). Diving and re-surfacing didn't fix it, but saving and re-loading did.

It may not help but just thought I would throw in my 2 in case it does :)

PortsmouthProwler
06-10-2009, 11:23 PM
If it helps, your propulsion flow is:

* SURFACE: Diesels -> Generators -> Motors -> Screws
and when you're recharging batteries, some of the juice from the generators is siphoned off to the Batteries.

* SUBMERGED: Batteries -> Motors -> Screws

Check each component in the power flow.

ozwally
06-11-2009, 05:02 AM
Thanks for the replies!

I tried reloading a few times, but still the same happens.

I also checked all components (clicked on the list at the left for port/starboard propulsion) and as far as I could tell nothing was damaged.

In the end I restarted the campaign, and found another convoy of equal size and got more tonnage :) Though I had this same issue again where I got shot up by a DD coming from the fog and the engines went. I think it has to be damage judging this, but for some reason my damage control station doesnt show any of the propulsion components as destroyed (though some were damaged and got repaired). Wonder if thats a possible bug? Anyone else had that?

Also a lesson leaned. Be careful when attacking in fog. Ended up ramming a ship

PortsmouthProwler
06-11-2009, 06:41 AM
It may or may not necessarily be a message.

If, when you mouse over the 'red bar', the damage value, or whatever you want to call it, is equal to 1 (1.00), then that component is gone, it's destroyed. Whether you always get a message, I dunno, but 1 means totally kaput.

You were good enough to state your fuel situation, so I know that wasn't the issue, but, FWIW, you can have batteries that are damaged and that will never recharge back to 100%. You can use them, but their capacitance has been reduced for the rest of the patrol. If you ever see this, watch your recharge, 'cuz you can burn through your fuel all too quickly trying to recharge batteries that never are fully charged. You have to manually decouple the recharger in this case.

Also, while I'm thinking about it, if you load a save where the boat was submerged, you might have serious issues on getting back to a true surfaced condition. It's a glitch - you'll be at 16 feet depth, but the CO2 keeps going up and the crew can suffocate on a sunny day. Just something to be aware of - avoid saving while underwater, if you can. I just reload again if I have this, seems to work, but the best thing is to save only on the surface with no contacts and no land nearby.

Vandy
06-19-2009, 07:49 AM
Hi, I'm Vandy and very new to Subsim. I bought SH4+UB a few weeks ago and im now looking at running a proper campaign rather then just doing a few missions. One problem iv found is that no matter how I save my game, whenever I load it up the sub takes damage, even if there's no-one about for miles. I invariably get a damaged hull, which is a pest as I lose about 5 points each time, so by the end of a patrol I could be dead from just loading up. Has anyone had similar experiences or know any fixes?

Vandy

Morpheus
06-19-2009, 11:32 AM
@ozwally (http://www.subsim.com/radioroom/member.php?u=221428)

you need a hero aboard, not sure what title this one has, perhaps "Master Engineer" or something similar, he can also repair equip that has been totaly wrecked (i.e. 1.0 damage).

get one aboard for your next patrol ;)

a depth charge teared appart my fuel tank the day bevore ... no dieselspitting hero for that issue yet ^^

kr morph

Loud_Silence
06-19-2009, 11:50 AM
A bit of advise: for future crazy surface engagements, also use torpedoes. There is absolutely nothing like aiming your torps by turning the boat and see your target go kaboom... Tell your crew to cover, flying pieces of meat and blood can be extremely disgusting